Bug 979585 - pulp-consumer does not advertise the -u flag in its helptext
pulp-consumer does not advertise the -u flag in its helptext
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: consumers (Show other bugs)
2.1.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:45 EDT by Randy Barlow
Modified: 2015-02-28 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:57:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 361 None None None Never

  None (edit)
Description Randy Barlow 2013-06-28 16:45:42 EDT
If you do not authenticate to pulp when registering a consumer, it will present this error message to you:

# pulp-consumer register --consumer-id limeade
Authentication Failed

A valid Pulp user is required to register a new consumer. Please double check
the username and password and attempt the request again.

It turns out that there is a -u flag that can be passed to this command, but the help text doesn't advertise the flag. Also, the error text doesn't suggest that you should use it.

It also seems that the -u flag should perhaps be required.
Comment 1 Sayli Karmarkar 2013-07-03 12:13:57 EDT
I think there is a duplicate bug on this. Please verify when fixing this bug.
Comment 2 Brian Bouterse 2015-02-28 16:57:28 EST
Moved to https://pulp.plan.io/issues/361

Note You need to log in before you can comment on or make changes to this bug.