Bug 979591 - Port Forwarding Error for scaled application, Not able to reproduce the final url
Port Forwarding Error for scaled application, Not able to reproduce the final...
Status: CLOSED DUPLICATE of bug 907742
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:56 EDT by Shams
Modified: 2015-05-14 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 15:00:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shams 2013-06-28 16:56:38 EDT
Description of problem:
Cannot port-forward for MySQL database ports on scaling app

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. gem update rhc
2.
3.

Actual results:
C:\Users\SHAMS>rhc port-forward -a www -d
DEBUG: Connecting to https://openshift.redhat.com/broker/rest/api
DEBUG: Getting all domains
Password: ********
DEBUG: Getting all domains
DEBUG: Finding domain shamsmobi
DEBUG: Getting all domains
DEBUG: Finding application :name => www, :framework =>
DEBUG: Getting all applications for domain shamsmobi
Using ssh://51cde8975973ca2b4700001f@www-shamsmobi.rhcloud.com...
Checking available ports...
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f0b738>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f0b048>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f0a9a0>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f0a250>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f09ce0>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f09740>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f17570>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f16f28>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f16898>
DEBUG: #<RHC::Commands::ForwardingSpec:0x1f161a8>
Forwarding ports
DEBUG: ["127.7.174.2", 8080, "127.7.174.2", 8080]
DEBUG: ["127.7.174.3", 8080, "127.7.174.3", 8080]
DEBUG: ["127.7.174.1", 3528, "127.7.174.1", 3528]
DEBUG: ["127.7.174.1", 4447, "127.7.174.1", 4447]
DEBUG: ["127.7.174.1", 5445, "127.7.174.1", 5445]
DEBUG: ["127.7.174.1", 5455, "127.7.174.1", 5455]
DEBUG: ["127.7.174.1", 8080, "127.7.174.1", 8080]
DEBUG: ["127.7.174.1", 9990, "127.7.174.1", 9990]
DEBUG: ["127.7.174.1", 9999, "127.7.174.1", 9999]
DEBUG: ["51cdeba2e0b8cd67a8000030-shamsmobi.rhcloud.com", 43436, "51cdeba2e0b8cd67a8000030-shamsmobi.rhcloud.com", 43436]
  Service Connect to            Forward to
  ======= ================ ==== ================
  haproxy 127.7.174.2:8080  =>  127.7.174.2:8080
  haproxy 127.7.174.3:8080  =>  127.7.174.3:8080
  java    127.7.174.1:3528  =>  127.7.174.1:3528
  java    127.7.174.1:4447  =>  127.7.174.1:4447
  java    127.7.174.1:5445  =>  127.7.174.1:5445
  java    127.7.174.1:5455  =>  127.7.174.1:5455
  java    127.7.174.1:8080  =>  127.7.174.1:8080
  java    127.7.174.1:9990  =>  127.7.174.1:9990
  java    127.7.174.1:9999  =>  127.7.174.1:9999
Error forwarding some port(s). You can try to forward manually by running:
ssh -N -L 51cdeba2e0b8cd67a8000030-shamsmobi.rhcloud.com:43436:51cdeba2e0b8cd67a8000030-shamsmobi.rhcloud.com:43436 51cde8975973ca2b4700001f@www-shamsmobi.rhcloud.com

Expected results:


Additional info:
Comment 1 Jessica Forrester 2013-07-08 15:00:03 EDT
This was reproducible on version 1.4.8 of the rhc gem but is no longer reproducible from version 1.5.13 and up.  Based on changes to the way we format the output of the port-forwarding results, it does not like look you have 1.5.13 or later.  Please install the latest rhc gem (currently at 1.10.7).

To check your rhc version run:
gem rhc list

*** This bug has been marked as a duplicate of bug 907742 ***

Note You need to log in before you can comment on or make changes to this bug.