This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979731 - firewalld times out during boot, causes long boot time
firewalld times out during boot, causes long boot time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-29 21:32 EDT by Alan Schmidt
Modified: 2013-10-22 10:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 20:23:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Schmidt 2013-06-29 21:32:46 EDT
Description of problem:

When i upgraded to F19-beta, I had some difficulty booting. Once I disabled RHGB, I found a 30-45-second pause where firewalld and avahi flip back and forth forbidding the system to boot until they have finished failing.

The system log says this about firewalld:

systemd[1]: firewalld.service operation timed out. Terminating.

/var/log/firewalld is empty.

The system doesn't seem to boot up at all with RHGB teardrop being displayed. If you cancel the Fedora teardrop thing by pressing the down-arrow BEFORE the firewalld/avahi waiting message displays, the boot process will eventually move forward. I haven't had much luck if I boot and go get coffee and forget to cancel RHGB first.

This is just my home laptop, and it was a dirty upgrade from F18-F19 using FedUp, which otherwise really went quite well.
Comment 1 Thomas Woerner 2013-07-01 07:21:50 EDT
There has been a problem with with a firewalld version in beta, but this only happened if firewalld was stopped using systemd.

Please update to the latest firewalld version in F-19. Please report if the problem is still there, then.
Comment 2 Alan Schmidt 2013-07-01 11:08:29 EDT
Will do (I'm at work now, so it'll be a few hours).

I turned firewalld off Saturday since--as I studied my startup process--it DOES startup the iptables firewall first anyway, and I already understand that one.
Comment 3 Alan Schmidt 2013-07-01 20:23:59 EDT
yum update doesn't reveal any newer versions of firewalld.

I'm using:

firewalld-0.3.3-2.fc19.noarch

HOWEVER, when I booted this evening with firewalld DISABLED, I let RHGB go, and it did the same thing (stopped on the teardrop logo screen with the teardrop full). The disk stopped spinning, and nothing would do to restore control but to kill power.

Upon rebooting, and down-arrowing the RHGB off, this time it paused with the red Cylon asterisks for a good 60 seconds trying to load Network Manager (unlike with RHGB going, the disk never stops spinning).

ANYWAY, doing a:

systemctl start firewalld

...when the system is completely started up works FINE, so I've got something ELSE going on.

I'll be darned if I can figure out how to REPORT it, but I feel like firewalld isn't actually at fault like I thought at first.
Comment 4 Cristian Ciupitu 2013-10-21 21:08:34 EDT
I'm having a similar issue with firewalld-0.3.7-1.fc19.noarch, but when restarting after booting.
Comment 5 Thomas Woerner 2013-10-22 06:56:34 EDT
Cristian: What is the issue exactly? What is happening?
Comment 6 Cristian Ciupitu 2013-10-22 10:36:28 EDT
I think it was a one time thing only, maybe caused by a combination with libvirtd.  If it happens again, I'll try to provide more details.

Note You need to log in before you can comment on or make changes to this bug.