Bug 979743 - [rhevm] Failed install RHEVM 3.3 - '/var/lib/pgsql/data/pg_log' File exists
[rhevm] Failed install RHEVM 3.3 - '/var/lib/pgsql/data/pg_log' File exists
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Ofer Schreiber
vvyazmin@redhat.com
integration
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 03:41 EDT by vvyazmin@redhat.com
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 03:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs engine-setup, engine-db-install (7.14 KB, application/x-gzip)
2013-06-30 03:41 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-06-30 03:41:37 EDT
Created attachment 766995 [details]
## Logs engine-setup, engine-db-install

Description of problem: 
Failed install RHEVM 3.3 - '/var/lib/pgsql/data/pg_log' File exists


Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS3 environment:

RHEVM: rhevm-3.3.0-0.5.master.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. I have RHEVM server with RHEVM 3.2 SF18 install on it
2. Run following command:
rhevm-cleanup -u
yum -y remove rhevm* vdsm-bootstrap
rm -rf /var/log/ovirt-engine/*; rm -rf /tmp/*; rm -rf /usr/share/pgsql/*; rm -rf /usr/share/ovirt-engine/*
yum clean all
3. Edit REPO file for RHEVM 3.3
4. Run following command:
yum install rhevm
engine-setup
  
Actual results:
Failed install RHEVM 3.3, failed on “Creating Database... “ step (log attached)

Expected results:
Successfully install RHEVM 3.3 environment

Impact on user:
Failed install RHEVM 3.3 environment

Workaround:
Run following command:
yum -y remove jboss* 
yum -y remove postgres* 
yum install rhevm
engine-setup

Additional info:

IMHO, a root of problem is that RHEVM instalation don't verify if PostgreSQL already install.

/var/log/ovirt-engine/engine-db-install-2013_06_27_15_00_52.log

Initializing database: mkdir: cannot create directory `/var/lib/pgsql/data/pg_log': File exists

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 2 Moran Goldboim 2013-06-30 07:58:21 EDT
-Can you please explain the usecase here or what are you trying to achieve, i imagine it's a negative test case (can you please explain what you are trying to do) and if it's a regression than from which version?
Comment 4 vvyazmin@redhat.com 2013-08-08 10:28:53 EDT
Install RHEVM 3.3 environment on servers which on past had RHEVM 3.2 environment. This done, because I don't want install OS from the scratch. I want use same OS.
Comment 5 Ofer Schreiber 2013-08-22 07:07:49 EDT
Does this issue happens with the new otopi based setup?
We've solved many issues in that area, can you please re-test this case?
Comment 6 Ofer Schreiber 2013-08-28 03:27:16 EDT
Closing this bug, as it's look like a test error.
You should never have removed /usr/share/pgsql/*, it's simply wrong.

If this issue still happens on the new otopi based setup, please re-open.

Note You need to log in before you can comment on or make changes to this bug.