Bug 979744 - "nova list" with "--tenant" filter doesn't work
"nova list" with "--tenant" filter doesn't work
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Jakub Ruzicka
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 03:44 EDT by Rami Vaknin
Modified: 2014-09-08 01:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 10:15:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1134382 None None None Never

  None (edit)
Description Rami Vaknin 2013-06-30 03:44:12 EDT
Description of problem:
The command argument that lets admin to list the instances of a specific tenant doesn't work:

nova list --tenant <tenant_id or tenant_name, the doc is not clear here>

The output is empty although there are instances on the queried tenant.

Note that "--all-tenant" argument works well.


Version-Release number of selected component (if applicable):
Grizzly on rhel6.4, python-nova-2013.1.2-2.el6ost

How reproducible:
100% (at leat in my env)
Comment 2 Jakub Ruzicka 2013-11-05 11:51:56 EST
I confirmed this is still broken.

Please file an upstream bug and link the External Tracker:

https://bugs.launchpad.net/python-novaclient/+filebug

This isn't important enough for 4.0.
Comment 3 Rami Vaknin 2013-11-05 16:02:14 EST
(In reply to Jakub Ruzicka from comment #2)
> I confirmed this is still broken.
> 
> Please file an upstream bug and link the External Tracker:
> 
> https://bugs.launchpad.net/python-novaclient/+filebug
> 
> This isn't important enough for 4.0.

I found an upstream bug about this issue[1], it was closed as Invalid with the explanation that a filter can be applied only when using the --all-tenant, which means that the working syntax is:

nova list --all-tenant --tenant <a_tenant_name>

I checked this syntax and it works, however, I still think this is a bug because the syntax is different in other openstack cli commands where filtering on a non-admin tenant by an admin user.

[1] https://bugs.launchpad.net/python-novaclient/+bug/1134382
Comment 4 Jakub Ruzicka 2013-11-07 10:15:47 EST
So the problem here is weird but intended behavior rather than an incorrect one.

Upstream thinks this isn't a bug and I think changing this isn't worth downstream effort so I'm closing.

Please feel free to file upstream Wishlist bug!

Note You need to log in before you can comment on or make changes to this bug.