Bug 979747 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses on the file registry.i686.bin.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:18dbf0a9dc904e808125a3adeac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 04:15 EDT by Mikhail
Modified: 2013-07-01 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 07:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2013-06-30 04:15:35 EDT
Description of problem:
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses on the file registry.i686.bin.

*****  Plugin file (36.8 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin file (36.8 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin catchall_labels (23.2 confidence) suggests  ********************

If you want to allow totem-video-thumbnailer to have unlink access on the registry.i686.bin file
Then you need to change the label on registry.i686.bin
Do
# semanage fcontext -a -t FILE_TYPE 'registry.i686.bin'
where FILE_TYPE is one of the following: gstreamer_home_t, thumb_home_t, thumb_tmp_t, thumb_tmpfs_t, user_fonts_cache_t. 
Then execute: 
restorecon -v 'registry.i686.bin'


*****  Plugin catchall (5.04 confidence) suggests  ***************************

If you believe that totem-video-thumbnailer should be allowed unlink access on the registry.i686.bin file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                system_u:object_r:file_t:s0
Target Objects                registry.i686.bin [ file ]
Source                        totem-video-thu
Source Path                   /usr/bin/totem-video-thumbnailer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           totem-3.8.2-1.fc19.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.i686 #1 SMP Tue Jun
                              11 20:01:50 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-06-30 14:15:10 YEKT
Last Seen                     2013-06-30 14:15:10 YEKT
Local ID                      31820607-2a22-4df0-9a88-7048b8d18c31

Raw Audit Messages
type=AVC msg=audit(1372580110.46:414): avc:  denied  { unlink } for  pid=1952 comm="totem-video-thu" name="registry.i686.bin" dev="sdb" ino=74057982 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:file_t:s0 tclass=file


type=SYSCALL msg=audit(1372580110.46:414): arch=i386 syscall=rename success=no exit=EACCES a0=9068d30 a1=901f9b8 a2=b6d77000 a3=9175120 items=0 ppid=1778 pid=1952 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: totem-video-thu,thumb_t,file_t,file,unlink

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.i686
type:           libreport
Comment 1 Daniel Walsh 2013-07-01 06:28:24 EDT
This looks like you had a mislabeled home directory or thumbnail viewer was trying to create and remove content from a disk without labels.

restorecon -R -v ~/

Should fix any label problem in your homedir.
Comment 2 Miroslav Grepl 2013-07-01 07:01:15 EDT
Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.