Bug 979760 - [abrt] libreoffice-core-3.6.6.2-9.fc18: SdrPage::TRG_GetMasterPage: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.6.6.2-9.fc18: SdrPage::TRG_GetMasterPage: Process /...
Status: CLOSED DUPLICATE of bug 1014137
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:fb1a4bd5d16272ac587d7209e76...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 05:54 EDT by Max Wu
Modified: 2013-10-01 10:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 06:13:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (44.24 KB, text/plain)
2013-06-30 05:54 EDT, Max Wu
no flags Details
File: cgroup (130 bytes, text/plain)
2013-06-30 05:54 EDT, Max Wu
no flags Details
File: core_backtrace (6.15 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: dso_list (23.23 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: environ (2.40 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: maps (105.34 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: open_fds (1.34 KB, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: proc_pid_status (951 bytes, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details
File: var_log_messages (348 bytes, text/plain)
2013-06-30 05:55 EDT, Max Wu
no flags Details

  None (edit)
Description Max Wu 2013-06-30 05:54:48 EDT
Description of problem:
Insert about 8 pictures, and it crash.

Version-Release number of selected component:
libreoffice-core-3.6.6.2-9.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --session=1028c1d320b210000137257554500000156040120 --nologo
crash_function: SdrPage::TRG_GetMasterPage
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 SdrPage::TRG_GetMasterPage at /usr/src/debug/libreoffice-3.6.6.2/svx/source/svdraw/svdpage.cxx:1724
 #1 SdDrawDocument::SetMasterPage at /usr/src/debug/libreoffice-3.6.6.2/sd/source/core/drawdoc3.cxx:1438
 #2 sd::toolpanel::controls::DocumentHelper::AssignMasterPageToPage at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/toolpanel/controls/DocumentHelper.cxx:481
 #3 sd::toolpanel::controls::DocumentHelper::AssignMasterPageToPageList at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/toolpanel/controls/DocumentHelper.cxx:357
 #4 sd::toolpanel::controls::RecentMasterPagesSelector::AssignMasterPageToPageList at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/toolpanel/controls/RecentMasterPagesSelector.cxx:132
 #5 sd::toolpanel::controls::MasterPagesSelector::AssignMasterPageToAllSlides at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/toolpanel/controls/MasterPagesSelector.cxx:367
 #6 sd::toolpanel::controls::MasterPagesSelector::Execute at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/toolpanel/controls/MasterPagesSelector.cxx:529
 #7 CallExec at /usr/src/debug/libreoffice-3.6.6.2/sfx2/inc/sfx2/shell.hxx:199
 #8 SfxDispatcher::Call_Impl at /usr/src/debug/libreoffice-3.6.6.2/sfx2/source/control/dispatch.cxx:270
 #9 SfxDispatcher::Execute at /usr/src/debug/libreoffice-3.6.6.2/sfx2/source/control/dispatch.cxx:1097
Comment 1 Max Wu 2013-06-30 05:54:53 EDT
Created attachment 767026 [details]
File: backtrace
Comment 2 Max Wu 2013-06-30 05:54:56 EDT
Created attachment 767027 [details]
File: cgroup
Comment 3 Max Wu 2013-06-30 05:55:00 EDT
Created attachment 767028 [details]
File: core_backtrace
Comment 4 Max Wu 2013-06-30 05:55:03 EDT
Created attachment 767029 [details]
File: dso_list
Comment 5 Max Wu 2013-06-30 05:55:07 EDT
Created attachment 767030 [details]
File: environ
Comment 6 Max Wu 2013-06-30 05:55:10 EDT
Created attachment 767031 [details]
File: limits
Comment 7 Max Wu 2013-06-30 05:55:14 EDT
Created attachment 767032 [details]
File: maps
Comment 8 Max Wu 2013-06-30 05:55:17 EDT
Created attachment 767033 [details]
File: open_fds
Comment 9 Max Wu 2013-06-30 05:55:21 EDT
Created attachment 767034 [details]
File: proc_pid_status
Comment 10 Max Wu 2013-06-30 05:55:24 EDT
Created attachment 767035 [details]
File: var_log_messages
Comment 11 David Tardon 2013-07-11 03:57:03 EDT
Is this reproducible?
Comment 12 Caolan McNamara 2013-10-01 10:36:28 EDT
I suspect 1014137 is the same problem as this, but still unknown how to get it to happen

*** This bug has been marked as a duplicate of bug 1014137 ***

Note You need to log in before you can comment on or make changes to this bug.