Bug 979772 - [rhevm_33] - RFE - Interface disabled within the VM OS should be reported in webadmin
[rhevm_33] - RFE - Interface disabled within the VM OS should be reported in ...
Status: CLOSED DUPLICATE of bug 979771
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
infra
:
Depends On: 770447 979765
Blocks: 979771
  Show dependency treegraph
 
Reported: 2013-06-30 08:19 EDT by David Botzer
Modified: 2016-02-10 14:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979765
Environment:
Last Closed: 2013-07-05 02:56:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2013-06-30 08:19:36 EDT
+++ This bug was initially created as a clone of Bug #979765 +++

Description of problem:
RFE - RHEV-Agent should report when Interface is disabled within the VM OS,  webadmin->VM Tab -> Network Interfaces subtub
for example, 'ifdown eth0' within the vm 

Version-Release number of selected component (if applicable):
3.3/is3
rhev-agent.x86_64 0:2.3.16-7.el6_2

How reproducible:
always

Steps to Reproduce:
1.install rhevm
2.create vm (rhel,Win)
3.open Spice console on VM
4.disable the Vnic within the console

Actual results:
VM's Vnic is displayed in webadmin as 'up' (link is up)

Expected results:
Should display VM's Vnic, in webadmin, as 'down' (link is down)

Additional info:
In addition, in Network Intercaes Subtub-> there is a guest agent data tab
Where its possible to display the reason - 
e.x user cmd initiated ifdown
e.x 
   Unplugged, no memory left, OS not responding / stuck
   Network loaded 99% traffic

--- Additional comment from David Botzer on 2013-06-30 07:31:14 EDT ---

The dependencies should be: Engine depends on VDSM depends on Guest Agent.
Comment 1 Itamar Heim 2013-07-05 02:56:24 EDT

*** This bug has been marked as a duplicate of bug 979771 ***

Note You need to log in before you can comment on or make changes to this bug.