Bug 979779 - [abrt] gnome-abrt-0.2.12-3.fc19: g_thread_new: Process /usr/bin/python2.7 was killed by signal 5 (SIGTRAP)
[abrt] gnome-abrt-0.2.12-3.fc19: g_thread_new: Process /usr/bin/python2.7 was...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:f328065b2066d8512d235eed33f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 09:03 EDT by Sylvain Petreolle
Modified: 2016-11-30 19:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 08:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.42 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: cgroup (141 bytes, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: core_backtrace (8.54 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: dso_list (10.42 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: environ (1.82 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: maps (41.06 KB, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: open_fds (545 bytes, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2013-06-30 09:03 EDT, Sylvain Petreolle
no flags Details

  None (edit)
Description Sylvain Petreolle 2013-06-30 09:03:14 EDT
Description of problem:
abrt-gui crashed after I lost my internet connection.

Version-Release number of selected component:
gnome-abrt-0.2.12-3.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        python /usr/bin/gnome-abrt
crash_function: g_thread_new
executable:     /usr/bin/python2.7
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            500
var_log_messages: Jun 30 14:13:42 virt abrt[20232]: Saved core dump of pid 20231 (/usr/bin/python2.7) to /var/tmp/abrt/ccpp-2013-06-30-14:13:41-20231 (32362496 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_thread_new at gthread.c:839
 #3 _g_dbus_shared_thread_ref at gdbusprivate.c:306
 #4 _g_dbus_worker_new at gdbusprivate.c:1680
 #5 initable_init at gdbusconnection.c:2640
 #6 g_bus_get_sync at gdbusconnection.c:6882
 #7 g_daemon_vfs_init at gdaemonvfs.c:297
 #8 g_type_create_instance at gtype.c:1917
 #9 g_object_constructor at gobject.c:1855
 #12 try_implementation at giomodule.c:759
 #13 _g_io_module_get_default at giomodule.c:858
Comment 1 Sylvain Petreolle 2013-06-30 09:03:19 EDT
Created attachment 767072 [details]
File: backtrace
Comment 2 Sylvain Petreolle 2013-06-30 09:03:22 EDT
Created attachment 767073 [details]
File: cgroup
Comment 3 Sylvain Petreolle 2013-06-30 09:03:25 EDT
Created attachment 767074 [details]
File: core_backtrace
Comment 4 Sylvain Petreolle 2013-06-30 09:03:28 EDT
Created attachment 767075 [details]
File: dso_list
Comment 5 Sylvain Petreolle 2013-06-30 09:03:31 EDT
Created attachment 767076 [details]
File: environ
Comment 6 Sylvain Petreolle 2013-06-30 09:03:35 EDT
Created attachment 767077 [details]
File: limits
Comment 7 Sylvain Petreolle 2013-06-30 09:03:38 EDT
Created attachment 767078 [details]
File: maps
Comment 8 Sylvain Petreolle 2013-06-30 09:03:41 EDT
Created attachment 767079 [details]
File: open_fds
Comment 9 Sylvain Petreolle 2013-06-30 09:03:44 EDT
Created attachment 767080 [details]
File: proc_pid_status
Comment 10 Jakub Filak 2013-10-14 08:29:27 EDT
Thank you for the report. The crash occurred because of insufficient resources to create another thread, or a system-imposed limit on the number of threads was encountered. The latter case may occur in two ways: the RLIMIT_NPROC soft resource limit (set  via  setrlimit(2)),  which  limits  the  number  of  process for a real user ID, was reached; or the kernel's system-wide limit on the number of threads, /proc/sys/kernel/threads-max, was reached. Closing as NOTABUG but, please feel free to report any further bugs you find.
Comment 11 Sylvain Petreolle 2013-10-15 19:34:23 EDT
Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.