Bug 979810 - latexmk, evince-dvi contains unnecessary dependency on texlive
latexmk, evince-dvi contains unnecessary dependency on texlive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: latexmk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 15:25 EDT by RudraB
Modified: 2013-07-01 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 11:36:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RudraB 2013-06-30 15:25:19 EDT
Description of problem:
When trying to install evince-dvi (and latexmk, separately) the shows dependency on texlive distribution which was not there in f18.


Version-Release number of selected component (if applicable):

 evince-dvi            x86_64 3.8.2-1.fc19       
How reproducible:
try to install evince-dvi via yum

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jerry James 2013-07-01 11:01:23 EDT
If you want to file bugs against two products, you need to file two separate bugs.  I am not the evince-dvi maintainer, so I cannot do anything to fix the evince-dvi problem.

I am the latexmk maintainer, but I don't understand the problem.  Since latexmk invokes LaTeX, it needs a dependency on "tex(latex)", which is exactly what it has.  What, exactly, is the problem you are experiencing?  You left out the "actual results" and "expected results" part of your report, which is precisely the part I need to understand the problem.
Comment 2 RudraB 2013-07-01 11:29:01 EDT
Jerry,
Thanks for your concern on this vaguely written bug. 
The problem is, latexmk depends on texlive at /usr/share/.
Given that, as the regular criteria, it searches /usr/share to check if texlive already exists.
Given that, the fedora's texlive distro is always older then that is available in ctan, I installed it from ctan; which is installed in /usr/local. 
I made a softlink of /usr/local/texlive to /usr/share.
but then, possibly, the expected directory structure of /usr/share/texlive is different from what is given by ctan, even when I have a ctan exist, installing latexmk (and evince-dvi, if mkasik is also reading this), still install all the texlive.
I had same situation in f18, and latexmk did not make any objection. The problem is more dominant for evince-dvi then latexmk as latexmk is there in ctan itself.
Probably I should not have include latexmk as the problematic.
Comment 3 RudraB 2013-07-01 11:29:22 EDT
Jerry,
Thanks for your concern on this vaguely written bug. 
The problem is, latexmk depends on texlive at /usr/share/.
Given that, as the regular criteria, it searches /usr/share to check if texlive already exists.
Given that, the fedora's texlive distro is always older then that is available in ctan, I installed it from ctan; which is installed in /usr/local. 
I made a softlink of /usr/local/texlive to /usr/share.
but then, possibly, the expected directory structure of /usr/share/texlive is different from what is given by ctan, even when I have a ctan exist, installing latexmk (and evince-dvi, if mkasik is also reading this), still install all the texlive.
I had same situation in f18, and latexmk did not make any objection. The problem is more dominant for evince-dvi then latexmk as latexmk is there in ctan itself.
Probably I should not have include latexmk as the problematic.
Comment 4 Jerry James 2013-07-01 11:36:48 EDT
(In reply to RudraB from comment #3)
> The problem is, latexmk depends on texlive at /usr/share/.

That is not true; latexmk depends on "tex(latex)".  That dependency can be satisfied by any package that has "Provides: tex(latex)" in its spec file.  Currently, only texlive-latex has that Provides, but that doesn't mean that some other package couldn't Provide it also.

> Given that, the fedora's texlive distro is always older then that is
> available in ctan, I installed it from ctan; which is installed in
> /usr/local. 

That is the point where you stop getting support from Fedora.  Sorry.  If you want to compile and install competing versions of software provided by Fedora, you can certainly do that, but you're on your own if you run into trouble.  Good luck.

Note You need to log in before you can comment on or make changes to this bug.