Bug 979819 - Typo in script to generate /usr/libexec/openldap/generate-server-cert.sh
Typo in script to generate /usr/libexec/openldap/generate-server-cert.sh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
David Spurek
: EasyFix, Patch
Depends On:
Blocks: 1087490
  Show dependency treegraph
 
Reported: 2013-06-30 16:41 EDT by Ulrich Habel
Modified: 2015-03-02 00:27 EST (History)
3 users (show)

See Also:
Fixed In Version: openldap-2.4.39-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1087490 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:57:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Habel 2013-06-30 16:41:51 EDT
Description of problem:

There is a typo "pritnf" vs "printf" in the usage description of the script generate-server-cert.sh which causes the help display to fail.

./generate-server-cert.sh -h
./generate-server-cert.sh: option requires an argument -- h
usage: generate-server-cert.sh [-d certdb-dir] [-n cert-name]
                               [-p password-file] [-h hostnames]
./generate-server-cert.sh: line 28: pritnf: command not found


Version-Release number of selected component (if applicable):

openldap-servers-2.4.23-32

How reproducible:

Everytime

Steps to Reproduce:
1. Run the script ./generate-server-cert.sh -h
2.
3.

Actual results:

failing help display

Expected results:

help display correctly

Additional info:

n/a
Comment 1 Jan Synacek 2013-07-01 02:42:04 EDT
Indeed, thanks for catching this!
Comment 2 RHEL Product and Program Management 2013-10-13 19:26:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 errata-xmlrpc 2014-10-14 00:57:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1426.html

Note You need to log in before you can comment on or make changes to this bug.