Bug 979923 - [virtio-win][netkvm]Download big file was interrupted when using netkvm driver
[virtio-win][netkvm]Download big file was interrupted when using netkvm driver
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 03:28 EDT by Mike Cao
Modified: 2015-11-22 22:37 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-09 03:48:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2013-07-01 03:28:54 EDT
Description of problem:
I have a win8-64 guest as my laptop ,Now I am downloading en_windows_server_2012_r2_datacenter_preview_x64_dvd_2358570.iso ,the download operation always be interrupted 

Version-Release number of selected component (if applicable):
virtio-win-prewhql-65

How reproducible:
almost 100%

Steps to Reproduce:
1.Start VM with virtio-net-pci
CLI:
/usr/libexec/qemu-kvm -name win8-64 -S -M rhel5.4.0 -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -uuid 6ad42fad-761f-e082-aadc-c4096097c030 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/win8-64.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -no-shutdown -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/libvirt/images/mikeshare/win8-wlk-virtio.raw,if=none,id=drive-virtio-disk0,format=raw,serial=mike_cao,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/var/lib/libvirt/images/mikeshare/data_image.raw,if=none,id=drive-virtio-disk1,format=raw,cache=writeback -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk1,id=virtio-disk1 -drive file=/var/lib/libvirt/images/mikeshare/virtio-win-1.6.4.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/var/lib/libvirt/images/mikeshare/virtio-win-prewhql-41-win8.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:b6:ff:a6,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
2.Download en_windows_server_2012_r2_datacenter_preview_x64_dvd_2358570.iso from MSDN


Actual results:
it need almost 10 hours to finish the download operation ,less than 1 hours ,the download operation has been interrupted 

Expected results:
ISO could be downloaded successfully


Additional info:
Comment 2 Yan Vugenfirer 2013-07-23 10:14:25 EDT
Hi Mike,

Was the network active after the download was interrupted? Ping to guest and\or from guest and etc?

Thanks,
Yan.
Comment 3 Mike Cao 2013-08-01 02:54:44 EDT
(In reply to Yan Vugenfirer from comment #2)
> Hi Mike,
> 
> Was the network active after the download was interrupted? Ping to guest
> and\or from guest and etc?
> 
> Thanks,
> Yan.

Hi, yan

Sorry for late response .The network is still active 

Mike
Comment 4 Yan Vugenfirer 2013-08-06 08:37:54 EDT
Hi Mike,

Did you use Akamai NetSession for the download (this is what MS request me to install when I want to download Win2012 R2 preview)? 

Thanks,
Yan.
Comment 5 Mike Cao 2013-08-06 22:46:41 EDT
(In reply to Yan Vugenfirer from comment #4)
> Hi Mike,
> 
> Did you use Akamai NetSession for the download (this is what MS request me
> to install when I want to download Win2012 R2 preview)? 
> 
> Thanks,
> Yan.

Do you mean Microsoft File Transfer Manager ?
If so ,I use it ,it is interpreted at 99% downloading progress 

BTW ,Using Microsoft File Transfer Manager looks better to me ,I can not 100% reproduce this issue now 

Thanks,
Mike
Comment 6 RHEL Product and Program Management 2013-10-13 23:15:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Yan Vugenfirer 2013-12-24 07:35:31 EST
Hi Mike,

I still cannot reproduce this bug and was able to download the images of Windows 2012 server R2 without interruption.


How can we test if it was MS server problem or driver problem?

Do you have continuos file transfer over network test as part of the functional testing?

Best regards,
Yan.
Comment 9 Yan Vugenfirer 2014-01-14 10:08:32 EST
Hi Mike,

Can you compare to direct download from your laptop in same environment?

Thanks,
Yan.
Comment 10 Mike Cao 2014-01-16 22:44:28 EST
(In reply to Yan Vugenfirer from comment #8)
> Hi Mike,
> 
> I still cannot reproduce this bug and was able to download the images of
> Windows 2012 server R2 without interruption.
> 
> 
> How can we test if it was MS server problem or driver problem?
> 
> Do you have continuos file transfer over network test as part of the
> functional testing?

Any luck to limit your speed of network to 100MB as downloading the image from MSFT need more or less 2 hours . 
> 
> Best regards,
> Yan.
Comment 11 Mike Cao 2014-01-16 22:45:36 EST
(In reply to Yan Vugenfirer from comment #9)
> Hi Mike,
> 
> Can you compare to direct download from your laptop in same environment?

I did not get it .do you mean whether it can be reproduced on baremetal to see whether it is a MSFT server issue ?

> 
> Thanks,
> Yan.
Comment 12 Yan Vugenfirer 2014-01-19 04:48:06 EST
(In reply to Mike Cao from comment #11)
> (In reply to Yan Vugenfirer from comment #9)
> > Hi Mike,
> > 
> > Can you compare to direct download from your laptop in same environment?
> 
> I did not get it .do you mean whether it can be reproduced on baremetal to
> see whether it is a MSFT server issue ?

Yes.

> 
> > 
> > Thanks,
> > Yan.
Comment 13 Yan Vugenfirer 2014-02-25 07:51:55 EST
Hi Mike,

We still cannot reproduce this issue. Can you provide Wireshark recordings of the download that is interrupted?

Best regards,
Yan.
Comment 14 Mike Cao 2014-06-12 21:22:32 EDT
(In reply to Yan Vugenfirer from comment #13)
> Hi Mike,
> 
> We still cannot reproduce this issue. Can you provide Wireshark recordings
> of the download that is interrupted?
> 
> Best regards,
> Yan.

Hi, It seems the network issue ,I can reproduce this issue on RHEL7 host

Mike

Note You need to log in before you can comment on or make changes to this bug.