Bug 979933 - No message pop-up after adding dictionary/new text file in i-t-b
No message pop-up after adding dictionary/new text file in i-t-b
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 03:49 EDT by Pravin Satpute
Modified: 2013-07-11 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-typing-booster-1.2.1-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 23:01:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pravin Satpute 2013-07-01 03:49:42 EDT
Description of problem:
First of all really nice feature.

I added on sample-text file. But after adding it i did not received any confirmation message regarding it done successfully. So i just guess it happened and done other testing. 

Version-Release number of selected component (if applicable):
ibus-typing-booster-1.2.0-1.fc19.noarch

How reproducible:
everytime

Steps to Reproduce:
1. Select Regional and Language Settings.
2. Select setting icon next to Marathi- IN (Hunspell)
3. Select "Dictionaries and Personal Data" Tab
4. Click on "Learn from text file"
5. Select local text file havin Marathi language words

Actual results:
After selecting file no confirmation message happens.

Expected results:
Should get some confirmation regarding file added successfully.

Additional info:
It is possible that users feel that file not added successfully and can do multiple attempts.

Even i think it will be better, if selected files words are already in database better to indicate user that almost x% words are present in database. But dunno it can have some other side effect as well.
Comment 1 Mike FABIAN 2013-07-01 04:34:33 EDT
(In reply to Pravin Satpute from comment #0)
> Actual results:
> After selecting file no confirmation message happens.
> 
> Expected results:
> Should get some confirmation regarding file added successfully.

Would a spinner indicating that reading the file is in progress
which disappears when finished help?

Currently, the setup tool becomes gray while the file is read and
returns to normal colours when it is done. That is difficult to see
when short files are read and looks not nice when a long file is read.
When a long file is read, this may look as if something is broken.  A
spinner would make this more obvious. But for that I would need to do
the reading of the file in a different thread.

A confirmation box at the end is probably a good idea anyway and
independent from the spinner.

> Even i think it will be better, if selected files words are already in
> database better to indicate user that almost x% words are present in
> database. But dunno it can have some other side effect as well.

I am thinking about adding a “statistics” tab to the setup tool to
show information about how many entries are in the database and what
the count is.
Comment 2 Pravin Satpute 2013-07-01 05:16:16 EDT
1. Yes, Spinner will also do the job of indicating to user that file is added.


2. "Statistics" tab is good idea. Just wondering since we have more than .1Million entries. It will be too big may be. User need to scroll down lot. 

a. Might be statistics only for user added entries will do here?

We are talking two different features on same bug ;)
Comment 3 Mike FABIAN 2013-07-01 08:02:15 EDT
(In reply to Pravin Satpute from comment #2)
> 2. "Statistics" tab is good idea. Just wondering since we have more than
> .1Million entries. It will be too big may be. User need to scroll down lot. 
> 
> a. Might be statistics only for user added entries will do here?

I thought about statistics like:

- “You saved 80% of the keystrokes today, 75% last week”
- “The database has 234395 entries with a total count of 578349.”
  If the same text files is used for learning twice, the number of entries
  will not increase but the counts will increase, i.e. the weight for
  the trigrams taken from that file will double.
- maybe something graphical which shows how the counts are distributed
Comment 4 Pravin Satpute 2013-07-02 04:45:27 EDT
Yes this idea looks nice. I initially thought you are planning to show all words in database to users, so was bit doubtful. 

Now clear, Thanks !!
Comment 6 Fedora Update System 2013-07-03 10:38:18 EDT
ibus-typing-booster-1.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc17
Comment 7 Fedora Update System 2013-07-03 10:41:39 EDT
ibus-typing-booster-1.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc18
Comment 8 Fedora Update System 2013-07-03 10:42:54 EDT
ibus-typing-booster-1.2.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc19
Comment 9 Fedora Update System 2013-07-03 20:52:09 EDT
Package ibus-typing-booster-1.2.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12234/ibus-typing-booster-1.2.1-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-07-11 23:01:34 EDT
ibus-typing-booster-1.2.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-07-11 23:12:29 EDT
ibus-typing-booster-1.2.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-07-11 23:18:02 EDT
ibus-typing-booster-1.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.