Bug 979939 - It will be good to remove punctuation marks and quote from words before adding to Database.
It will be good to remove punctuation marks and quote from words before addin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 03:55 EDT by Pravin Satpute
Modified: 2013-07-11 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-typing-booster-1.2.1-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 23:01:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text file created by taking some content from online newspaper. (6.38 KB, application/octet-stream)
2013-07-01 03:55 EDT, Pravin Satpute
no flags Details

  None (edit)
Description Pravin Satpute 2013-07-01 03:55:53 EDT
Created attachment 767274 [details]
text file created by taking some content from online newspaper.

Description of problem:
While adding text file using "Learn from text file" feature of i-t-b, i observed that some words are getting added with the punctuation marks. Because of that one will only get that in suggestion box when he will start with single quote etc.

Version-Release number of selected component (if applicable):
ibus-typing-booster-1.2.0-1.fc19.noarch

How reproducible:
everytime

Steps to Reproduce:
1. Add file provided in Attachment. 
2. स्पेक्ट्रमपासून  (with Marathi-IN hunspell) - Itrans input keystroke are "spe"
3. but it does not come in suggestion box.

Actual results:
It is not coming in suggestion list.

Expected results:
it should come in suggestion list.

Additional info:
If we start word with single quote, it is coming in suggestion box. Since it is getting added as it is in db.
Comment 1 Mike FABIAN 2013-07-01 04:26:37 EDT
Yes, I know that the punctuation is added to the database.

Surely something must be improved there,
I am still thinking how to handle punctuation best.
Comment 3 Fedora Update System 2013-07-03 10:38:23 EDT
ibus-typing-booster-1.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc17
Comment 4 Fedora Update System 2013-07-03 10:41:44 EDT
ibus-typing-booster-1.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc18
Comment 5 Fedora Update System 2013-07-03 10:43:00 EDT
ibus-typing-booster-1.2.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.1-1.fc19
Comment 6 Fedora Update System 2013-07-03 20:52:14 EDT
Package ibus-typing-booster-1.2.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12234/ibus-typing-booster-1.2.1-1.fc19
then log in and leave karma (feedback).
Comment 7 Pravin Satpute 2013-07-04 02:25:28 EDT
Thanks for quick fix. 

It is really good that you are considering Unicode characters type for punctuation. Since present scope of i-t-b is more language and some scripts like Arabic has there specific punct. marks.

Earlier while creating custom db for marathi-typing-booster etc. I specifically removed all panct. from sample text files prior creating database.
Comment 8 Fedora Update System 2013-07-11 23:01:41 EDT
ibus-typing-booster-1.2.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-07-11 23:12:34 EDT
ibus-typing-booster-1.2.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-11 23:18:07 EDT
ibus-typing-booster-1.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.