This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979979 - Icons created by virt inspector interface not used by anyone
Icons created by virt inspector interface not used by anyone
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On: 905238
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 05:08 EDT by hyao@redhat.com
Modified: 2014-06-17 20:00 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 905238
Environment:
Last Closed: 2014-06-13 07:14:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log (8.16 KB, text/plain)
2013-08-15 04:35 EDT, hyao@redhat.com
no flags Details
screenshot when highquality=0 (33.41 KB, image/png)
2013-08-30 01:38 EDT, hyao@redhat.com
no flags Details
screenshot when highquality=1 (32.35 KB, image/png)
2013-08-30 01:39 EDT, hyao@redhat.com
no flags Details

  None (edit)
Description hyao@redhat.com 2013-07-01 05:08:44 EDT
This bug reproduced on rhel7 with the following packages: 

Version-Release number of selected component (if applicable):
libvirt-1.0.6-1.el7.x86_64
virt-manager-0.10.0-1.el7.noarch
libguestfs-tools-c-1.22.2-1.el7.x86_64
libguestfs-tools-1.22.2-1.el7.x86_64

Steps to reproduce: 
1. prepare xp and rhel guest.
2. open virt-manager

Actual results:
no icon on the screen

Expected results:
icon are displayed on virt-manager.


Additional info: 
This bug does not reproduce on rhel6.4
 
libguestfs-tools-c-1.20.8-5.el6.x86_64
virt-manager-0.9.0-18.el6.x86_64
libguestfs-tools-1.20.8-5.el6.x86_64
libvirt-0.10.2-18.el6_4.8.x86_64



+++ This bug was initially created as a clone of Bug #905238 +++

Description of problem:

In my quest to understand where the guestfs-whatever transient virtual
machine were coming from, I started this thread:

http://lists.fedoraproject.org/pipermail/virt/2013-January/003550.html

Near the end I was asked to submit a bug report about the icons
(at least I think that's what I was asked :-), so this is it.

The virt-inspector tool does indeed create an icon and embed it in the
xml. If I base64 decode it, it is even a png of a windows wavy flag,
which is probably what it should be for a windows xp virtual machine.

But, after going to all that trouble, virt-manager doesn't show it
anywhere that I can see. It isn't on the main window, and if I open
a VM, it isn't on the overview page. I couldn't think of any place else
to look for it.


Version-Release number of selected component (if applicable):
Here's all the packages with "virt" in the name:

libvirt-daemon-driver-secret-0.10.2.2-3.fc18.x86_64
libvirt-daemon-0.10.2.2-3.fc18.x86_64
virt-viewer-0.5.4-3.fc18.x86_64
virtuoso-opensource-6.1.6-1.fc18.x86_64
libvirt-0.10.2.2-3.fc18.x86_64
virt-top-1.0.8-3.fc18.x86_64
libvirt-daemon-driver-uml-0.10.2.2-3.fc18.x86_64
python-virtinst-0.600.3-2.fc18.noarch
libvirt-daemon-driver-nwfilter-0.10.2.2-3.fc18.x86_64
libvirt-gconfig-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-network-0.10.2.2-3.fc18.x86_64
perl-Sys-Virt-0.10.2-1.fc18.x86_64
libvirt-daemon-qemu-0.10.2.2-3.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-xen-0.10.2.2-3.fc18.x86_64
libvirt-gobject-0.1.5-1.fc18.x86_64
libvirt-client-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.2.2-3.fc18.x86_64
libvirt-python-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-storage-0.10.2.2-3.fc18.x86_64
virt-manager-0.9.4-4.fc18.noarch
libvirt-daemon-config-network-0.10.2.2-3.fc18.x86_64
libvirt-daemon-kvm-0.10.2.2-3.fc18.x86_64
libvirt-glib-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-interface-0.10.2.2-3.fc18.x86_64
redland-virtuoso-1.0.15-2.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.2.2-3.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.2.2-3.fc18.x86_64
virt-manager-common-0.9.4-4.fc18.noarch


How reproducible:
every time I run virt-manager

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
icon in the xml, no icon on the screen

Expected results:
visible icon somewhere?

Additional info:

--- Additional comment from Richard W.M. Jones on 2013-01-28 18:12:05 EST ---

$ base64 -di > icon.png 
iVBORw0KGgoAAAANSUhEUgAAABkAAAAUCAIAAAD3FQHqAAAD/klEQVQ4jbXUW0yTZxgH8C4c
Bo+ddMwEUQPBSUsppUcqUA4tFCoN0pYzCFjoutiFjiFgCbTQWhmxFsEDW2SCskghKCxDo7i5
sJGRILIlw02RRcPF1pGMDZk64zw8e63xxn1btov9L97LX97n/3zfS6P9T0FXCu4XYpcET2Th
qSJsYv78DtukTpZKpf8NWu3fja0stGxCx3oc0uBQySMDfU65ZkK5Sfo8/9a635mLNiaag9C1
BT+uwqOyO6XwZSLYs/mpleKdfTHmbgXhwsLCXBfkx2Yy/onGtji0s7CJge+J8JwRW5keLVyQ
0EsqZElvBOq7/PZNhLpmQ7sXNnzgWffuFbpEIqGGlj5sQns0tm5G2zrsz8SRSjQFzythIC08
oVCoMNJqTwXapqBzAXpXoGcZat1r+Xw+tXXvgAL3srExGJ0b8KMC7FM82AmXk8CZJ9lazlLX
+zSehbZZOLIIfavQdQsMdjaHw6G2POaw7w30qzm0YX1kr0l5Xh06xaP1B9Pe3CFNf+s13X5/
y6fgnIP3PdD3GzhmILdcGh0d/bd96Ros2VUt2vqBHLNbUtioVcgL5JzUYomymlZ7MtA2CQfn
4fgv0LsKe0YYSSmS2NhYCsV8eGWbdTGzdkVjRecg9o5hmeWhOHcprsgsKGZr6+mmQbBNQ8dN
6F6G9muv6Jq5bDabuq+6Q/crHKg2Y3UHui/hkVHcYX4iUvwglu/V7359V0OM3hirN3Nq2nh1
9hiHnavZnsBisXg8HoVlaPtDtw/zmrHpGI5Ooq0XNcbfY6U3E/LV/Y6XZgfXzg5FnD65ZXyI
OX8p/MFlRllhfGRkJIVVYDhdZH1caMUyO7oGcXgCazpQUXqbn/hFWoV42On79RB4LsKTrwCv
Ad6AG+fWi4QxTCaTwqqqmy2xoroRjR048BmeuIiVrRivWhKkHny7IeL80YDro/Dr54DfAF5/
yrkPi6KiosgHQdFXcd1Ppc2P8/Y82mVdthzw1Dju5lffE8gWxdkVPW1+k31w6yzcnQL81mvN
gaUujcvlkiVSWFJDfqm+PEOTkVWQlaRMSt2WmZA9wU4ZVekUZ1x+V9zw4zg8nPEOuAB3ptcU
58uEQqFYLI6Li3vREivEQa8GBUDAxrCNfv5+/i/7M3lMVZEqz8QdORT03Rm4TQa8+hQil/qk
P0YqTdjqjUgketEKCQlJlCeq8lTaci2DwfDx8fH19ZXlyMK14SqjxNHIG+8JmXYHuzs3V1fx
5LJ48kvHe0PxTrS3txu8aelqIadSqWTz2PJsOTeRS54XUvOzdkjI4sh0ZDQCEZHCGhsbMzxP
eno6OZOTk8nKdTpdREQE2Rch+N4IBAJSE5nu2aX+av0JMGKmahyMK+oAAAAASUVORK5CYII=
$ file icon.png 
icon.png: PNG image data, 25 x 20, 8-bit/color RGB, non-interlaced

It could be because the icon is too small for virt-manager
to display?  It does appear that libguestfs is creating a
valid PNG file however.

--- Additional comment from Richard W.M. Jones on 2013-01-28 18:31:42 EST ---

I don't see any "minimum size" or similar in the code.  The
code does try to resize the icon down to 16x16 for display
in the main manager window:

http://git.fedorahosted.org/cgit/virt-manager.git/tree/src/virtManager/manager.py#n936

--- Additional comment from Cole Robinson on 2013-06-13 15:55:13 EDT ---

Fixed upstream:

commit 91a97d439c97f0945b3caff3336119ede4a75ed6
Author: Cole Robinson <crobinso@redhat.com>
Date:   Thu Jun 13 15:54:12 2013 -0400

    manager: Fix loading libguestfs OS icons (bz 905238)

--- Additional comment from Fedora Update System on 2013-06-19 19:00:47 EDT ---

virt-manager-0.10.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-1.fc19

--- Additional comment from Fedora Update System on 2013-06-20 14:00:12 EDT ---

Package virt-manager-0.10.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11349/virt-manager-0.10.0-1.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-06-29 14:14:12 EDT ---

virt-manager-0.10.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Martin Kletzander 2013-07-02 02:11:10 EDT
Moving to POST with commit v0.10.0-14-g9d5c1cd:

commit 9d5c1cdb1c03a8c045ae94ab5324aa7dda68e695
Author: Richard W.M. Jones <rjones@redhat.com>
Date:   Fri Jun 28 18:45:53 2013 +0100

    inspection: Check can_set_row_none before setting icon to None.
Comment 7 hyao@redhat.com 2013-08-15 04:31:27 EDT
it seems the bug is partially fixed, only the rhel guest icon could be shown in virt-manager. Icon for the windows guest could not be displayed. 

Version: 
# rpm -qa libvirt virt-manager python-libguestfs libguestfs-tools* libguestfs-winsupport
libguestfs-winsupport-7.0-2.el7.x86_64
libvirt-1.1.1-2.el7.x86_64
python-libguestfs-1.22.5-3.el7.x86_64
libguestfs-tools-c-1.22.5-3.el7.x86_64
virt-manager-0.10.0-2.el7.noarch
libguestfs-tools-1.22.5-3.el7.x86_64

Steps:
1. Prepare guests two rhel and one windows xp.
Open virt-manager wait for about a few minute, then check the icon for the guest.

Actual Result:
Icons for the rhel guest are displayed but not for the windows xp.


Expected result:
Icon for all guests are displayed. 

Additional info: 
Use virt-inspector to extract the xml of guest XP and check if the icon element is availabel:
....
<icon>iVBORw0KGgoAAAANSUhEUgAAABkAAAAUCAIAAAD3FQHqAAAD/klEQVQ4jbXUW0yTZxgH8C4c
Bo+ddMwEUQPBSUsppUcqUA4tFCoN0pYzCFjoutiFjiFgCbTQWhmxFsEDW2SCskghKCxDo7i5
sJGRILIlw02RRcPF1pGMDZk64zw8e63xxn1btov9L97LX97n/3zfS6P9T0FXCu4XYpcET2Th
qSJsYv78DtukTpZKpf8NWu3fja0stGxCx3oc0uBQySMDfU65ZkK5Sfo8/9a635mLNiaag9C1
BT+uwqOyO6XwZSLYs/mpleKdfTHmbgXhwsLCXBfkx2Yy/onGtji0s7CJge+J8JwRW5keLVyQ
0EsqZElvBOq7/PZNhLpmQ7sXNnzgWffuFbpEIqGGlj5sQns0tm5G2zrsz8SRSjQFzythIC08
oVCoMNJqTwXapqBzAXpXoGcZat1r+Xw+tXXvgAL3srExGJ0b8KMC7FM82AmXk8CZJ9lazlLX
+zSehbZZOLIIfavQdQsMdjaHw6G2POaw7w30qzm0YX1kr0l5Xh06xaP1B9Pe3CFNf+s13X5/
y6fgnIP3PdD3GzhmILdcGh0d/bd96Ros2VUt2vqBHLNbUtioVcgL5JzUYomymlZ7MtA2CQfn
4fgv0LsKe0YYSSmS2NhYCsV8eGWbdTGzdkVjRecg9o5hmeWhOHcprsgsKGZr6+mmQbBNQ8dN
6F6G9muv6Jq5bDabuq+6Q/crHKg2Y3UHui/hkVHcYX4iUvwglu/V7359V0OM3hirN3Nq2nh1
9hiHnavZnsBisXg8HoVlaPtDtw/zmrHpGI5Ooq0XNcbfY6U3E/LV/Y6XZgfXzg5FnD65ZXyI
OX8p/MFlRllhfGRkJIVVYDhdZH1caMUyO7oGcXgCazpQUXqbn/hFWoV42On79RB4LsKTrwCv
Ad6AG+fWi4QxTCaTwqqqmy2xoroRjR048BmeuIiVrRivWhKkHny7IeL80YDro/Dr54DfAF5/
yrkPi6KiosgHQdFXcd1Ppc2P8/Y82mVdthzw1Dju5lffE8gWxdkVPW1+k31w6yzcnQL81mvN
gaUujcvlkiVSWFJDfqm+PEOTkVWQlaRMSt2WmZA9wU4ZVekUZ1x+V9zw4zg8nPEOuAB3ptcU
58uEQqFYLI6Li3vREivEQa8GBUDAxrCNfv5+/i/7M3lMVZEqz8QdORT03Rm4TQa8+hQil/qk
P0YqTdjqjUgketEKCQlJlCeq8lTaci2DwfDx8fH19ZXlyMK14SqjxNHIG+8JmXYHuzs3V1fx
5LJ48kvHe0PxTrS3txu8aelqIadSqWTz2PJsOTeRS54XUvOzdkjI4sh0ZDQCEZHCGhsbMzxP
eno6OZOTk8nKdTpdREQE2Rch+N4IBAJSE5nu2aX+av0JMGKmahyMK+oAAAAASUVORK5CYII=</icon>
  </operatingsystem>
</operatingsystems>

# base64 -i -d icon.data>icon.png
# file icon.png
icon.png: PNG image data, 25 x 20, 8-bit/color RGB, non-interlaced

I can view the icon by gimp.
Comment 8 hyao@redhat.com 2013-08-15 04:35:21 EDT
Created attachment 786862 [details]
virt-manager.log
Comment 9 Richard W.M. Jones 2013-08-15 04:43:13 EDT
libguestfs is definitely performing inspection and finding
icons:

2013-08-15 16:05:07,859 (inspection:244): qemu:///system:T2: detected operating system: linux rhel 6.4 (Red Hat Enterprise Linux Server release 6.4 (Santiago))
2013-08-15 16:05:07,860 (inspection:245): hostname: localhost.localdomain
2013-08-15 16:05:07,860 (inspection:247): icon: 16322 bytes
2013-08-15 16:05:07,860 (inspection:249): # apps: 996
2013-08-15 16:05:12,219 (inspection:244): qemu:///system:XP: detected operating system: windows windows 5.1 (Microsoft Windows XP)
2013-08-15 16:05:12,219 (inspection:245): hostname: redhat-03d93115
2013-08-15 16:05:12,220 (inspection:249): # apps: 1
2013-08-15 16:05:23,830 (inspection:244): qemu:///system:N: detected operating system: linux rhel 6.3 (Red Hat Enterprise Linux Server release 6.3 (Santiago))
2013-08-15 16:05:23,831 (inspection:245): hostname: localhost.localdomain
2013-08-15 16:05:23,831 (inspection:247): icon: 16322 bytes
2013-08-15 16:05:23,831 (inspection:249): # apps: 605

Those icons should appear in the interface.  I can see
that the patch has been applied to the source of
virt-manager-0.10.0-2.el7.  So something is going wrong here,
but I'm not clear what.
Comment 10 Martin Kletzander 2013-08-29 05:45:10 EDT
Correct me if I'm wrong, but for the windows guest there is no:

(inspection:247): icon: X bytes

message, but for the others there is, I'm guessing the inspection doesn't work.  Can you confirm/disprove my "hypothesis"?
Comment 11 Richard W.M. Jones 2013-08-29 06:05:03 EDT
OK, now I understand what's going on here.

virt-manager specifies that it wants a high quality icon:

virt-manager/virtManager/inspection.py:

   # string containing PNG data
   icon = g.inspect_get_icon(root, favicon=0, highquality=1)
   if icon == "":
       icon = None

However libguestfs doesn't know how to get high quality icons
from Windows guests, it can only get low-res ones:

libguestfs/src/inspect-icon.c:

  #if CAN_DO_WINDOWS
    /* We don't know how to get high quality icons from a Windows guest,
     * so disable this if high quality was specified.
     */
    if (!highquality)
      r = icon_windows (g, fs, &size);
  #endif

So this is in fact working as intended now.  We might consider
modifying virt-manager so it doesn't set the highquality flag,
but I suspect I added that because elsewhere in the virt-manager
UI we want to display the high resolution icon.

In any case, as long as icons for some guests are being displayed,
you can set this bug to VERIFIED.
Comment 12 Martin Kletzander 2013-08-29 06:34:05 EDT
Thank you for checking that out, I am highly unfamiliar with this.  Is the code preferring high quality icons even when highquality=0?  I'm asking to check whether doing something similar to this makes sense:

icon = g.inspect_get_icon(root, favicon=0, highquality=1)
if icon == "":
    icon = g.inspect_get_icon(root, favicon=0, highquality=1)
if icon == "":
    icon = None

In the meantime, I'm moving this back to QE (according to comment #11).
Comment 13 Richard W.M. Jones 2013-08-29 06:57:19 EDT
(In reply to Martin Kletzander from comment #12)
> Thank you for checking that out, I am highly unfamiliar with this.  Is the
> code preferring high quality icons even when highquality=0?  I'm asking to
> check whether doing something similar to this makes sense:
> 
> icon = g.inspect_get_icon(root, favicon=0, highquality=1)
> if icon == "":
>     icon = g.inspect_get_icon(root, favicon=0, highquality=1)
I'm assuming you mean                         ^^ highquality=0
> if icon == "":
>     icon = None

The answer is that libguestfs will prefer the highest quality
icon if you specify highquality=0, but may return a low quality
icon.  The "fallback" code above would NOT be necessary.  All
you would need to do is remove the highquality=1 flag.
http://libguestfs.org/guestfs.3.html#guestfs_inspect_get_icon

However: the low quality icons are sometimes really small, eg.
12x12 px.  I thought that virt-manager was displaying a larger
icon on the "Details" tab, but I can't find that in the code
now, so maybe I was imagining it.  Perhaps it would be fine to
remove the highquality=1 flag, but I guess someone will need to
test it.
Comment 14 hyao@redhat.com 2013-08-30 01:36:38 EDT
Rechecked on the following packages:
#  rpm -qa libvirt virt-manager python-libguestfs libguestfs-tools* libguestfs-winsupport
libvirt-1.1.1-2.el7.x86_64
libguestfs-tools-c-1.22.5-3.el7.x86_64
virt-manager-0.10.0-2.el7.noarch
libguestfs-tools-1.22.5-3.el7.x86_64
libguestfs-winsupport-7.0-2.el7.x86_64
python-libguestfs-1.22.5-3.el7.x86_64

Steps:
Get 3 windows guest, win8 ,windows2008, and winxp. change highquality=0 /usr/share/virt-manager/virtManager/inspection.py. 
Get the guest info by virt-inspector.

For winxp guest, icon item is availale, and the icon is displayed but ugly when highquality=0.  Get the screenshot form attachment hightquality_0.png. 

For win8 guest, icon item is available in the xml, as below. And the icon is displayed when highquality=0. 
# virt-inspector -d win8
<?xml version="1.0"?>
<operatingsystems>
  <operatingsystem>
    <root>/dev/sda2</root>
    <name>windows</name>
    <arch>x86_64</arch>
    <distro>windows</distro>
    <product_name>Windows 8 Enterprise</product_name>
    ......
    <applications/>    
<icon>iVBORw0KGgoAA.....[many lines ]Ro0bHD+Ine9k55UqlGGlp4rxa6N1/9MzUiDHAxd92/OBR5a/c
rBvLr4Edl3IivjFjG/47gh/vydJwN0Lz4psN1fqdnyuLn//PHj8H8NP9/Z8AAwApzyYXNiDe
XgAAAABJRU5ErkJggg==</icon>
  </operatingsystem>
</operatingsystems>

And in comments 11 "However libguestfs doesn't know how to get high quality iconsfrom Windows guests, it can only get low-res ones:", so when highquality=1 flag is set, the icon is not displayed. These are expected result.

For windows2008, icon item is not available, so no matter highquality=1 is set or not, no icon item available for this guest. This is expected result too. 
# virt-inspector -d re
<?xml version="1.0"?>
<operatingsystems>
  <operatingsystem>
    <root>/dev/sdb</root>
    <name>windows</name>
    <arch>i686</arch>
    <distro>windows</distro>
    <product_name>Microsoft Windows Server 2008</product_name>
    <major_version>6</major_version>
    <minor_version>0</minor_version>
    <format>installer</format>
    <mountpoints>
      <mountpoint dev="/dev/sdb">/</mountpoint>
    </mountpoints>
    <filesystems>
      <filesystem dev="/dev/sdb">
        <type>udf</type>
        <label>KRTMSVOL_EN_DVD</label>
        <uuid>2009-04-11-12-00-00-00</uuid>
      </filesystem>
    </filesystems>
    <applications/>
  </operatingsystem>
</operatingsystems>


Based on the mentioned test reuslts, verify the bug.
Comment 15 hyao@redhat.com 2013-08-30 01:38:33 EDT
Created attachment 792026 [details]
screenshot when highquality=0
Comment 16 hyao@redhat.com 2013-08-30 01:39:08 EDT
Created attachment 792027 [details]
screenshot when highquality=1
Comment 17 hyao@redhat.com 2013-08-30 02:21:13 EDT
(In reply to hyao@redhat.com from comment #14)
> Rechecked on the following packages:
> #  rpm -qa libvirt virt-manager python-libguestfs libguestfs-tools*
> libguestfs-winsupport
> libvirt-1.1.1-2.el7.x86_64
> libguestfs-tools-c-1.22.5-3.el7.x86_64
> virt-manager-0.10.0-2.el7.noarch
> libguestfs-tools-1.22.5-3.el7.x86_64
> libguestfs-winsupport-7.0-2.el7.x86_64
> python-libguestfs-1.22.5-3.el7.x86_64
> 
> Steps:
> Get 3 windows guest, win8 ,windows2008, and winxp. change highquality=0
> /usr/share/virt-manager/virtManager/inspection.py. 
> Get the guest info by virt-inspector.
> 
> For winxp guest, icon item is availale, and the icon is displayed but ugly
> when highquality=0.  Get the screenshot form attachment hightquality_0.png. 
> 
> For win8 guest, icon item is available in the xml, as below. And the icon is
> displayed when highquality=0. 
> # virt-inspector -d win8
> <?xml version="1.0"?>
> <operatingsystems>
>   <operatingsystem>
>     <root>/dev/sda2</root>
>     <name>windows</name>
>     <arch>x86_64</arch>
>     <distro>windows</distro>
>     <product_name>Windows 8 Enterprise</product_name>
>     ......
>     <applications/>    
> <icon>iVBORw0KGgoAA.....[many lines
> ]Ro0bHD+Ine9k55UqlGGlp4rxa6N1/9MzUiDHAxd92/OBR5a/c
> rBvLr4Edl3IivjFjG/47gh/vydJwN0Lz4psN1fqdnyuLn//PHj8H8NP9/Z8AAwApzyYXNiDe
> XgAAAABJRU5ErkJggg==</icon>
>   </operatingsystem>
> </operatingsystems>
> 
> And in comments 11 "However libguestfs doesn't know how to get high quality
> iconsfrom Windows guests, it can only get low-res ones:", so when
> highquality=1 flag is set, the icon is not displayed. These are expected
> result.
> 
> For windows2008, icon item is not available, so no matter highquality=1 is
> set or not, no icon item available for this guest. This is expected result
> too. 
> # virt-inspector -d re
> <?xml version="1.0"?>
> <operatingsystems>
>   <operatingsystem>
>     <root>/dev/sdb</root>
>     <name>windows</name>
>     <arch>i686</arch>
>     <distro>windows</distro>
>     <product_name>Microsoft Windows Server 2008</product_name>
>     <major_version>6</major_version>
>     <minor_version>0</minor_version>
>     <format>installer</format>
>     <mountpoints>
>       <mountpoint dev="/dev/sdb">/</mountpoint>
>     </mountpoints>
>     <filesystems>
>       <filesystem dev="/dev/sdb">
>         <type>udf</type>
>         <label>KRTMSVOL_EN_DVD</label>
>         <uuid>2009-04-11-12-00-00-00</uuid>
>       </filesystem>
>     </filesystems>
>     <applications/>
>   </operatingsystem>
> </operatingsystems>
> 
> 
> Based on the mentioned test reuslts, verify the bug.

Since I changed the highquality flag to 0 manaully, it's expected to change to 0 in next patch. so I change the status to assigned. And pleases notice that the icon for windows 2008 is not displayed even highquality=0. Although the picture is not that good, and I think it's better to get one tiny icon than none.
Comment 18 Richard W.M. Jones 2013-08-30 05:49:39 EDT
libguestfs doesn't know how to get icons for any Windows
guest *except* Windows XP, Windows 7, Windows 8 (including
the server variants of those).  So not seeing an icon for
Windows 2008 is normal.

I think the low-quality Windows icons look terrible, and
we should *not* change the highquality setting.  Looks like
it's there fore a good reason.

Before anyone suggests including the icons in virt-manager,
we've explored that route and it's not legal because OS icons
are trademarked, non-free and subject to field of use restrictions.
Comment 19 Tom Horsley 2013-08-30 06:15:07 EDT
Could users maybe define their own icons? That would allow something more meaningful to the user than a generic OS icon might be.
Comment 20 Richard W.M. Jones 2013-08-30 06:46:34 EDT
You can set favicon=1 (virt-manager sets it to 0).  This
will pull an icon from a known location in the guest which
the user can override easily.  See:

http://libguestfs.org/guestfs.3.html#guestfs_inspect_get_icon
Comment 21 Martin Kletzander 2013-09-03 04:29:02 EDT
Moving back to ON_QA according to comment #18 mentioning highquality=0 is *not* what we want.  Please move to VERIFIED if there is nothing else to do so we can properly prioritize other BZs.  Thank you.
Comment 22 hyao@redhat.com 2013-09-03 06:20:36 EDT
Based on the previous comments 18, 16 and 21, change this bug to verified.
Comment 24 Ludek Smid 2014-06-13 07:14:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.