Bug 980051 - quota: crossing the soft-limit does not update the quotad.log
quota: crossing the soft-limit does not update the quotad.log
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 06:16 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
8 users (show)

See Also:
Fixed In Version: v3.4.0.12rhs.beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-07-01 06:16:01 EDT
Description of problem:
as per the design that I know, once the 90% of the limit is occupied there should be a message like "Usage crossed limit",

but it is not being found in the present logs


Version-Release number of selected component (if applicable):
[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-geo-replication-3.4.0.12rhs.beta1-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta1-1.el6rhs.x86_64
glusterfs-server-3.4.0.12rhs.beta1-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.12rhs.beta1-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta1-1.el6rhs.x86_64


How reproducible:
seen on this build,

Actual results:
[root@quota1 ~]# gluster volume info
 
Volume Name: dist-rep
Type: Distributed-Replicate
Volume ID: b1b80b68-b98b-4aab-a563-3c386c39b842
Status: Started
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: 10.70.37.98:/rhs/bricks/d1r1
Brick2: 10.70.37.174:/rhs/bricks/d1r2
Brick3: 10.70.37.136:/rhs/bricks/d2r1
Brick4: 10.70.37.168:/rhs/bricks/d2r2
Brick5: 10.70.37.98:/rhs/bricks/d3r1
Brick6: 10.70.37.174:/rhs/bricks/d3r2
Brick7: 10.70.37.136:/rhs/bricks/d4r1
Brick8: 10.70.37.168:/rhs/bricks/d4r2
Brick9: 10.70.37.98:/rhs/bricks/d5r1
Brick10: 10.70.37.174:/rhs/bricks/d5r2
Brick11: 10.70.37.136:/rhs/bricks/d6r1
Brick12: 10.70.37.168:/rhs/bricks/d6r2
Options Reconfigured:
features.quota: on

xattr dump from 10.70.37.98
[root@quota1 ~]# getfattr -m -d . -e hex /rhs/bricks/d
d1r1/ d3r1/ d5r1/ 
[root@quota1 ~]# getfattr -m -d . -e hex /rhs/bricks/d1r1/
[root@quota1 ~]# getfattr -m . -d -e hex /rhs/bricks/d1r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d1r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x0000000100000000555555547ffffffd
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000016a00000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842

[root@quota1 ~]# getfattr -m . -d -e hex /rhs/bricks/d3r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d3r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x0000000100000000aaaaaaa8d5555551
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000014e00000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842

[root@quota1 ~]# getfattr -m . -d -e hex /rhs/bricks/d5r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d5r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x0000000100000000000000002aaaaaa9
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000015600000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842

xattr dump from 10.70.37.136
[root@quota3 ~]# getfattr -m . -d -e hex /rhs/bricks/d2r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d2r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x00000001000000007ffffffeaaaaaaa7
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000014e00000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842

[root@quota3 ~]# getfattr -m . -d -e hex /rhs/bricks/d4r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d4r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x0000000100000000d5555552ffffffff
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000015f00000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842

[root@quota3 ~]# getfattr -m . -d -e hex /rhs/bricks/d6r1/
getfattr: Removing leading '/' from absolute path names
# file: rhs/bricks/d6r1/
security.selinux=0x73797374656d5f753a6f626a6563745f723a66696c655f743a733000
trusted.gfid=0x00000000000000000000000000000001
trusted.glusterfs.dht=0x00000001000000002aaaaaaa55555553
trusted.glusterfs.quota.dirty=0x3000
trusted.glusterfs.quota.size=0x0000000014c00000
trusted.glusterfs.volume-id=0xb1b80b68b98b4aaba5633c386c39b842


Expected results:
if the soft-limit is crossed, then the message should occur in quotad.log

Additional info:
sosreport remains same, as was foung with BZ 980043,
http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/980043/
Comment 2 vpshastry 2013-07-04 03:06:26 EDT
Working for me.
Comment 5 vpshastry 2013-07-16 06:31:52 EDT
Can you update the bug wrt to latest build? CHANGE: https://code.engineering.redhat.com/gerrit/9996 fixes the issue.
Comment 6 vpshastry 2013-07-19 07:49:43 EDT
Glusterd was sending the reconfigure while quotad had no code to handle it, so the quotad doesn't have the limit dir list. No limits means no operation leading to no log. As a temporary fix 685241463f75aa8d974a7c1cd024c99844cda919 we restart the quotad. The permanent patch link in the comment #5 fixes it by adding reconfigure code in the quotad.
Comment 8 Scott Haines 2013-09-23 18:39:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 9 Scott Haines 2013-09-23 18:43:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.