Bug 980159 - OSGiSubsystemTestCase is failing on IBMJDK due to NoClassDefFoundError: org.jboss.osgi.framework.BundleManager
OSGiSubsystemTestCase is failing on IBMJDK due to NoClassDefFoundError: org.j...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: OSGi (Show other bugs)
6.1.1
All Linux
high Severity high
: ---
: ---
Assigned To: Thomas Diesler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 10:50 EDT by Pavel Jelinek
Modified: 2013-07-22 11:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 03:02:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Jelinek 2013-07-01 10:50:37 EDT
testRejectExpressionsAS712, testRejectExpressionsAS713 and testTransformerAS712 are failing on IBMJDK. 

See 

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-IBMJDK6/25/jdk=ibm16,label_exp=RHEL5%26%26x86/testReport/org.jboss.as.osgi.parser/OSGiSubsystemTestCase/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-IBMJDK7/36/jdk=ibm17,label_exp=RHEL6%26%26x86/testReport/org.jboss.as.osgi.parser/OSGiSubsystemTestCase/

testRejectExpressionsAS712 stacktrace: 

java.lang.NoClassDefFoundError: org.jboss.osgi.framework.BundleManager
	at org.jboss.as.osgi.management.OSGiRuntimeResource.getBundleContext(OSGiRuntimeResource.java:214)
	at org.jboss.as.osgi.management.OSGiRuntimeResource.getBundleIDs(OSGiRuntimeResource.java:204)
	at org.jboss.as.osgi.management.OSGiRuntimeResource.getChildren(OSGiRuntimeResource.java:144)
	at org.jboss.as.controller.registry.AbstractModelResource$DelegateResource.getChildren(AbstractModelResource.java:255)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:245)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:232)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:219)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:247)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:232)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:219)
	at org.jboss.as.controller.registry.Resource$Tools.readModel(Resource.java:208)
	at org.jboss.as.controller.ModelControllerImpl.writeModel(ModelControllerImpl.java:476)
	at org.jboss.as.controller.OperationContextImpl.createPersistenceResource(OperationContextImpl.java:175)
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:360)
	at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:229)
	at org.jboss.as.controller.AbstractOperationContext.finishStep(AbstractOperationContext.java:514)
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:500)
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:322)
	at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:229)
	at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:224)
	at org.jboss.as.controller.ModelControllerImpl.internalExecute(ModelControllerImpl.java:194)
	at org.jboss.as.controller.ModelControllerImpl.execute(ModelControllerImpl.java:115)
	at org.jboss.as.model.test.ModelTestKernelServicesImpl.executeOperation(ModelTestKernelServicesImpl.java:232)
	at org.jboss.as.subsystem.test.KernelServicesImpl.executeOperation(KernelServicesImpl.java:180)
	at org.jboss.as.model.test.ModelTestUtils.checkFailedTransformedAddOperation(ModelTestUtils.java:534)
	at org.jboss.as.model.test.ModelTestUtils.checkFailedTransformedAddOperation(ModelTestUtils.java:529)
	at org.jboss.as.model.test.ModelTestUtils.checkFailedTransformedBootOperations(ModelTestUtils.java:516)
	at org.jboss.as.osgi.parser.OSGiSubsystemTestCase.testRejectExpressions1_0_0(OSGiSubsystemTestCase.java:329)
	at org.jboss.as.osgi.parser.OSGiSubsystemTestCase.testRejectExpressionsAS712(OSGiSubsystemTestCase.java:303)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
	at java.lang.reflect.Method.invoke(Method.java:611)
	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:30)
	at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
	at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
	at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:234)
	at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:133)
	at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:114)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
	at java.lang.reflect.Method.invoke(Method.java:611)
	at org.apache.maven.surefire.util.ReflectionUtils.invokeMethodWithArray(ReflectionUtils.java:188)
	at org.apache.maven.surefire.booter.ProviderFactory$ProviderProxy.invoke(ProviderFactory.java:166)
	at org.apache.maven.surefire.booter.ProviderFactory.invokeProvider(ProviderFactory.java:86)
	at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:101)
	at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:74)
Caused by: java.lang.ClassNotFoundException: org.jboss.osgi.framework.BundleManager
	at java.net.URLClassLoader.findClass(URLClassLoader.java:434)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:660)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:626)
	at org.jboss.as.model.test.ChildFirstClassLoader.loadClass(ChildFirstClassLoader.java:66)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:626)
	... 60 more
Comment 1 Thomas Diesler 2013-07-02 03:02:13 EDT
OSGi is going to get removed - you can disable the osgi testsuite.

Note You need to log in before you can comment on or make changes to this bug.