Bug 980272 - Error with viewing additional component information
Error with viewing additional component information
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Product Browser (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
matt jia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 19:40 EDT by Simon Green
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.4-4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 21:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Green 2013-07-01 19:40:41 EDT
Description of problem:
An SQL error occurs when trying to view additional component information in the Browse section

Version-Release number of selected component (if applicable):
4.4-3.5

How reproducible:
Always

Steps to Reproduce:
Browse » (select product) » Component tab » (click on a component name)

Actual results:
Software error:

DBI prepare: invalid number of arguments: got handle + 4, expected handle + between 1 and 2
Usage: $h->prepare($statement [, \%attr]) at /loader/0x1a43c170/Bugzilla/Extension/Browse/Queries.pm line 420.

For help, please send mail to the webmaster (bugzilla-owner@redhat.com), giving this error message and the time and date of the error. 

Expected results:
No SQL error :)


Additional info:
Know exactly where the problem is.
Comment 2 Simon Green 2013-07-01 20:10:49 EDT
Also fixed two other bugs with these pages:
 * The recently open and closed lists never were displayed
 * The recently closed lists were showing closed bugs that were recently opened, not recently closed.
Comment 4 Simon Green 2013-07-17 21:48:19 EDT
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.