Bug 980291 - instructions for generating own CA key and cert using tools such as openssl or genkey
instructions for generating own CA key and cert using tools such as openssl o...
Status: CLOSED WONTFIX
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Documentation (Show other bugs)
2.1
All All
medium Severity medium
: ---
: 2.1.2
Assigned To: Julie
Lana Brindley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 22:06 EDT by Anand Vaddarapu
Modified: 2016-02-18 01:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 20:53:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Vaddarapu 2013-07-01 22:06:49 EDT
Document URL: 
https://access.redhat.com/site/documentation/en-US/Red_Hat_Update_Infrastructure/2.1/html-single/Installation_Guide/index.html

Section Number and Name: 
Procedure 3.1. Configuring Red Hat Update Appliance SSL Certificates

Describe the issue: 
Below instructions gives an idea how to acquire CA certs from third party or generate your own. If someone wants to generate their own, there should be instructions to do that. 

"Acquire your company's root certificate and private key. Alternatively you can purchase one from a certificate authority (CA), or generate your own using tools such as openssl or genkey.
The CA key and certificate enables you to create SSL keys and certificates for the Red Hat Update Appliance and the CDS, as well as sign the entitlement certificates for the clients to access the CDS instances. "

Suggestions for improvement: 
Please document instructions for generating own CA key and cert using tools such as openssl or genkey.

Additional information:
Comment 2 Anand Vaddarapu 2013-07-29 00:16:35 EDT
Julie,

Its not requested by a customer. I asked this because if customers who wanted to know the steps then they open a case with Red Hat Support. Its good to be provide them those steps proactively.

Note You need to log in before you can comment on or make changes to this bug.