This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 980305 - win8-64 guest fai to migration on Q35- "migrate: State blocked by non-migratable device '0000:00:1f.2/ich9_ahci'"
win8-64 guest fai to migration on Q35- "migrate: State blocked by non-migrata...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 23:35 EDT by lijin
Modified: 2013-07-01 23:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 23:41:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2013-07-01 23:35:49 EDT
Description of problem:
When do migration with machine type q35,migration failed and qemu monitor displays "migrate: State blocked by non-migratable device '0000:00:1f.2/ich9_ahci'"
Change machine type from -M q35 to -M pc,not hit this issue

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
kernel-3.10.0-0.rc7.64.el7.x86_64
qemu-kvm-1.5.0-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot win8-64 guest in rhel7.0 host:
/usr/libexec/qemu-kvm   \
-drive file=win8-64-.qcow2,if=none,cache=unsafe,media=disk,format=qcow2,id=drive-ide0-0-1 \
-device ide-drive,id=ide1,drive=drive-ide0-0-1,bus=ide.1,bootindex=1 \
-vga cirrus \
-monitor stdio \
-vnc :2 \
-device ich9-usb-ehci1,id=ehci1 \
-device usb-tablet,id=tablet1,bus=ehci1.0 \
-boot menu=on \
-chardev file,path=/root/console.log,id=serial1 \
-device isa-serial,chardev=serial1,id=s1 \
-cpu 'SandyBridge',hv_relaxed  -M q35 \
-smp 4,maxcpus=4,cores=2,threads=1,sockets=2 -m 4096 \
-enable-kvm \

2.open the listening side:
/usr/libexec/qemu-kvm -drive file=win8-64-balloon-65.qcow2,if=none,cache=unsafe,media=disk,format=qcow2,id=drive-ide0-0-1 -device ide-drive,id=ide1,drive=drive-ide0-0-1,bus=ide.1,bootindex=1 -vga cirrus -monitor stdio -vnc :3 -device ich9-usb-ehci1,id=ehci1 -device usb-tablet,id=tablet1,bus=ehci1.0 -boot menu=on -chardev file,path=/root/console.log,id=serial1 -device isa-serial,chardev=serial1,id=s1 -cpu SandyBridge,hv_relaxed -M q35 -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 -m 4096 -enable-kvm -incoming tcp::5888

3.(qemu)migrate -d tcp:xx.xx.xx.xx:5888


Actual results:
after step 3:
migrate: State blocked by non-migratable device '0000:00:1f.2/ich9_ahci'

Expected results:
migration can be completed with no error.

Additional info:
Comment 2 juzhang 2013-07-01 23:41:42 EDT
Close as not bug since we do not support so far.
Comment 3 lijin 2013-07-01 23:42:55 EDT
close this bug as Q35 does not support migration.

Note You need to log in before you can comment on or make changes to this bug.