Bug 980315 - guest call trace when boot it with spice + qxl
guest call trace when boot it with spice + qxl
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
7.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 00:37 EDT by Sibiao Luo
Modified: 2014-06-18 05:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-20 13:19:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest call trace logs. (47.73 KB, text/plain)
2013-07-02 00:38 EDT, Sibiao Luo
no flags Details

  None (edit)
Description Sibiao Luo 2013-07-02 00:37:18 EDT
Description of problem:
Boot guest with spice+qxl, guest will call trace, hit it under both Q35 and pc-i440fx-1.5 machine type. If use spice+cirrus / vnc did not hit this issue.

Version-Release number of selected component (if applicable):
host info:
3.10.0-0.rc7.64.el7.x86_64
qemu-kvm-1.5.1-1.el7.x86_64
guest info:
3.10.0-0.rc7.64.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.boot guest with spice + qxl
e.g:/usr/libexec/qemu-kvm -M q35 -cpu SandyBridge -enable-kvm -m 4096 -smp 4,sockets=2,cores=2,threads=1 -no-kvm-pit-reinjection -name sluo -uuid 355a2475-4e03-4cdd-bf7b-5d6a59edaa61 -rtc base=localtime,clock=host,driftfix=slew -device pci-bridge,bus=pcie.0,id=bridge1,chassis_nr=1,addr=0x3 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=0,bus=bridge1,addr=0x4 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port1 -chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait -device virtserialport,chardev=channel2,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port2 -drive file=/home/RHEL-7.0-20130628.0-Server-x86_64.qcow3,if=none,id=drive-system-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop,serial="QEMU-DISK1" -device virtio-scsi-pci,num_queues=4,id=scsi0,bus=bridge1,addr=0x5 -device scsi-hd,bus=scsi0.0,drive=drive-system-disk,id=system-disk,bootindex=1 -device virtio-balloon-pci,id=ballooning,bus=bridge1,addr=0x6 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -netdev tap,id=hostnet0,vhost=on,queues=4,script=/etc/qemu-ifup -device virtio-net-pci,mq=on,vectors=17,netdev=hostnet0,id=virtio-net-pci0,mac=08:2e:5f:0a:0d:b1,bus=bridge1,addr=0x7,bootindex=2 -k en-us -boot menu=on -qmp tcp:0:4444,server,nowait -serial unix:/tmp/ttyS0,server,nowait -spice port=5931,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -monitor stdio
2.
3.

Actual results:
after step 1, guest will call trace, i will attach the log later.

Expected results:
it should have no any call trace with spice + qxl.

Additional info:
Comment 1 Sibiao Luo 2013-07-02 00:38:14 EDT
Created attachment 767616 [details]
guest call trace logs.
Comment 2 Sibiao Luo 2013-07-02 00:40:40 EDT
- spice info:
spice-server-0.12.3-1.el7.x86_64
spice-gtk-0.20-1.el7.x86_64
spice-gtk3-0.20-1.el7.x86_64
spice-gtk-tools-0.20-1.el7.x86_64
Comment 3 Neil 2013-07-31 21:11:49 EDT
Also seeing this on Fedora 19 guests.
Comment 4 Uri Lublin 2013-12-26 10:09:24 EST
Seems like a linux (kernel) qxl driver issue, moving to xorg-x11-drv-qxl
Comment 5 Søren Sandmann Pedersen 2014-01-10 14:27:07 EST
Does this happen with recent RHEL 7 kernels?
Comment 6 Sibiao Luo 2014-01-15 01:16:53 EST
(In reply to Søren Sandmann Pedersen from comment #5)
> Does this happen with recent RHEL 7 kernels?
Tried the recent rhel7 kernel with the same testing as comment #0 which did not meet such issue any more.

host info:
# uname -r && rpm -q qemu-kvm
3.10.0-66.el7.x86_64.debug
qemu-kvm-1.5.3-31.el7.x86_64
guest info:
# uname -r
3.10.0-66.el7.x86_64.debug

Best Regards,
sluo
Comment 7 Søren Sandmann Pedersen 2014-01-20 13:19:50 EST
(In reply to Sibiao Luo from comment #6)

> Tried the recent rhel7 kernel with the same testing as comment #0 which did
> not meet such issue any more.

Okay, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.