Bug 980348 - Dist-geo-rep: If .ssh directory not present(on slave cluster) then 'create push-pem force' is unable to put required keys and as a result geo-rep session is in faluty state
Dist-geo-rep: If .ssh directory not present(on slave cluster) then 'create pu...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 02:48 EDT by Rachana Patel
Modified: 2015-04-20 07:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-02 02:48:06 EDT
Description of problem:
Dist-geo-rep: If .ssh directory not present(on slave cluster) then 'create push-pem force' is unable to put required keys and as a result geo-rep session is in faluty state

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta1-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.have a slave cluster which do not have .ssh directory
2. from master copy ssh-copy-id
3. from master - gluster system:: execute gsec_create
4.  gluster volume geo-replication master_vol <slaveip::slave_vol> create push-pem force
5.gluster volume geo-replication master_vol <slaveip::slave_vol> start
6.gluster volume geo-replication master_vol <slaveip::slave_vol> status

Actual results:
[root@baratheon ~]# gluster volume geo-replication master1 10.70.43.110::slave status
NODE                        MASTER     SLAVE                  HEALTH    UPTIME       
-------------------------------------------------------------------------------------
baratheon.blr.redhat.com    master1    10.70.43.110::slave    faulty    N/A          
flash.blr.redhat.com        master1    10.70.43.110::slave    faulty    N/A          
batman.blr.redhat.com       master1    10.70.43.110::slave    faulty    N/A          
dragon.blr.redhat.com       master1    10.70.43.110::slave    faulty    N/A   

Expected results:
If .ssh Directory is not present, it should be created.

Additional info:
Comment 3 Vijaykumar Koppad 2013-07-10 04:40:17 EDT
It is working fine in the build, glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64.
Comment 4 Rachana Patel 2013-08-08 06:22:38 EDT
verified with -3.4.0.18rhs-1.el6rhs.x86_64
working as per expected result , hence moving to verified
Comment 5 Scott Haines 2013-09-23 18:38:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:28 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.