Bug 980350 - Issues with inbound and outbound elements under bandwidth and peak attribute of outbound element
Issues with inbound and outbound elements under bandwidth and peak attribute ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Michal Privoznik
Virtualization Bugs
: Upstream
Depends On: 976648
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 02:53 EDT by hongming
Modified: 2016-04-26 10:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-40.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976648
Environment:
Last Closed: 2014-10-14 00:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Michal Privoznik 2013-11-22 03:05:04 EST
This issue is fixed upstream for a while:

commit d7a4a9b2ffe134eaf33c1965ab29a0fae416e166
Author:     Michal Privoznik <mprivozn@redhat.com>
AuthorDate: Fri Jul 26 11:42:53 2013 +0200
Commit:     Michal Privoznik <mprivozn@redhat.com>
CommitDate: Fri Jul 26 11:45:10 2013 +0200

    formatdomain.html.in: Document implementation limitation of QoS
    
    The outbound/@peak is ignored (since QoS was introduced). This is due to
    kernel limitation of know allowing ingress filters to have peak just
    average rate. However, we should document this limitation to not confuse
    users.

v1.1.1-rc1-33-gd7a4a9b
Comment 4 hongming 2013-11-22 03:18:56 EST
According to comment 3 ,Closed the bug as VERIFIED.
Comment 5 Ademar Reis 2014-06-23 10:13:32 EDT
(In reply to Michal Privoznik from comment #3)
> This issue is fixed upstream for a while:
> 
> commit d7a4a9b2ffe134eaf33c1965ab29a0fae416e166
> Author:     Michal Privoznik <mprivozn@redhat.com>
> AuthorDate: Fri Jul 26 11:42:53 2013 +0200
> Commit:     Michal Privoznik <mprivozn@redhat.com>
> CommitDate: Fri Jul 26 11:45:10 2013 +0200
> 
>     formatdomain.html.in: Document implementation limitation of QoS
>     
>     The outbound/@peak is ignored (since QoS was introduced). This is due to
>     kernel limitation of know allowing ingress filters to have peak just
>     average rate. However, we should document this limitation to not confuse
>     users.
> 
> v1.1.1-rc1-33-gd7a4a9b

(In reply to hongming from comment #4)
> According to comment 3 ,Closed the bug as VERIFIED.

I can't find this commit in the RHEL-6 libvirt git. Are you sure this was backported or inherited in RHEL-6? Please point me to the downstream commit.

In the meantime, I'm reopening to keep it on the radar.
Comment 6 Jiri Denemark 2014-06-23 13:35:29 EDT
Of course it wasn't a nobody even said it was. Michal just pointed out the upstream commit which fixed this bug. Not sure why QA moved the bug to VERIFIED right away...
Comment 9 hongming 2014-06-30 23:19:43 EDT
Verify it as follows. 

# rpm -qa|grep libvirt
libvirt-0.10.2-40.el6.x86_64
libvirt-snmp-0.0.2-4.el6.x86_64
libvirt-debuginfo-0.10.2-40.el6.x86_64
libvirt-java-devel-0.4.9-1.el6.noarch
libvirt-devel-0.10.2-40.el6.x86_64
libvirt-python-0.10.2-40.el6.x86_64
libvirt-client-0.10.2-40.el6.x86_64
libvirt-java-0.4.9-1.el6.noarch


# vim /usr/share/doc/libvirt-devel-0.10.2/formatdomain.html

2811    Note the limitation of implementation: the <code>peak</code> attribute in
2812    <code>outbound</code> element is ignored (as linux ingress filters don't
2813    know it yet). <span class="since">Since 0.9.4</span>
Comment 11 errata-xmlrpc 2014-10-14 00:16:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.