Bug 980356 - 3.2.2. Install JBoss Enterprise Application Platform 6 (Zip Installation) - jar xvf is not a good way for unzipping EAP distro
3.2.2. Install JBoss Enterprise Application Platform 6 (Zip Installation) - j...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.1.1
Assigned To: Russell Dickenson
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 03:19 EDT by Radim Hatlapatka
Modified: 2014-08-14 11:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 6895, Installation Guide-6.1-1 Build Date: 02-07-2013 10:05:17 Topic ID: 252-473080 [Specified]
Last Closed: 2013-09-16 16:27:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-07-02 03:19:28 EDT
Title: Install JBoss Enterprise Application Platform 6 (Zip Installation)
Procedure 3.2. Zip File Installation

Describe the issue:

For HP-UX there is used "jar" utility for unzipping of EAP distribution, but jar doesn't follow permissions and removes executable.

On HP-UX is also available "unzip" utility which works correctly


Suggestions for improvement:

Use for unzipping "unzip" utility as it doesn't remove permissions set in zip.


Additional typo bug in the 3.2.2. Install JBoss Enterprise Application Platform 6 (Zip Installation) :

In the *Result* subsection is typo. There should not be slash at the end of EAP_HOME/
Comment 2 Russell Dickenson 2013-07-07 19:46:38 EDT
I have corrected this issue in the EAP 6 documentation. Once similar bugs are corrected I will produce an updated revision of the document for validation.
Comment 3 Russell Dickenson 2013-07-09 23:59:31 EDT
The amended text, which specifies that the "unzip" utility should be used to extract the contents of the Zip [1].

Since the unzip utility is not available on HP-UX by default, I have added it to the list of prerequisites [2].

Before validating these changes, confirm that you're viewing revision 1.0-6 (or later).

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html-single/Installation_Guide/index.html#Install_JBoss_Enterprise_Application_Platform_6_Zip_Installation

[2] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html-single/Installation_Guide/index.html#Installation_Prerequisites_for_JBoss_Enterprise_Application_Platform_6
Comment 4 Radim Hatlapatka 2013-07-10 02:47:45 EDT
Seems OK now

Note You need to log in before you can comment on or make changes to this bug.