Bug 980371 - An exception occurred when view "lsblk" diagnostic utilities in Diagnostic page.
An exception occurred when view "lsblk" diagnostic utilities in Diagnostic page.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 03:47 EDT by cshao
Modified: 2014-01-21 14:42 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
An exception occurred when viewing "lsblk" diagnostic utilities in the Diagnostic page: 'ascii' codec can't decode byte 0xe2 in position 142: ordinal not in range(128)' This issue was fixed in a different build and ovirt can output the correct information when viewing all diagnostic utilities in the Diagnostic page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:42:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16554 None None None Never

  None (edit)
Description cshao 2013-07-02 03:47:16 EDT
Description of problem:
An exception occurred when view "lsblk" diagnostic utilities in Diagnostic page.

====================
An exception occurred
'ascii' codec can't decode byte 0xe2 in position 142: ordinal not in range(128)
====================

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch  

How reproducible:
100%


Steps to Reproduce:
1. Install rhevh6.5
2. Enter Diagnostic page.
3. Select "lsblk" tools to view.

Actual results:
1. An exception occurred when view "lsblk" diagnostic utilities in Diagnostic page.
2. Press F2 key to drop to shell, run command "lsblk" can show the correct info.

Expected results:
RHEV-H can output the correct info when view all diagnostic utilities in Diagnostic page.

Additional info:
Comment 3 Fabian Deutsch 2013-07-08 04:50:05 EDT
Chen,

could you provide the output of lsblk on that machine?
Comment 4 cshao 2013-07-08 05:57:47 EDT
(In reply to Fabian Deutsch from comment #3)
> Chen,
> 
> could you provide the output of lsblk on that machine?

TUI:
====================
An exception occurred
'ascii' codec can't decode byte 0xe2 in position 142: ordinal not in range(128)


CMD:
====================
# lsblk 
NAME                      MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0                       7:0    0 133.4M  1 loop 
loop1                       7:1    0   1.5G  1 loop 
└─live-rw (dm-0)          253:0    0   1.5G  0 dm   /
loop2                       7:2    0   512M  0 loop 
└─live-rw (dm-0)          253:0    0   1.5G  0 dm   /
sr0                        11:0    1   192M  0 rom  
vda                       252:0    0   9.8G  0 disk 
├─vda1                    252:1    0   243M  0 part 
├─vda2                    252:2    0   244M  0 part 
├─vda3                    252:3    0   244M  0 part /dev/.initramfs/live
└─vda4                    252:4    0   9.1G  0 part 
  ├─HostVG-Swap (dm-1)    253:1    0   2.4G  0 lvm  [SWAP]
  ├─HostVG-Config (dm-2)  253:2    0     8M  0 lvm  /config
  ├─HostVG-Logging (dm-3) 253:3    0     2G  0 lvm  /var/log
  └─HostVG-Data (dm-4)    253:4    0   4.6G  0 lvm  /data
Comment 5 Fabian Deutsch 2013-07-08 08:19:11 EDT
Thanks. That doesn't look suspicious.

Could you try to reproduce the problem with this build, once it's built:
http://jenkins.ovirt.org/view/ovirt_node/job/ovirt-node-iso-devel/2701/
Comment 6 cshao 2013-07-10 06:54:12 EDT
(In reply to Fabian Deutsch from comment #5)
> Thanks. That doesn't look suspicious.
> 
> Could you try to reproduce the problem with this build, once it's built:
> http://jenkins.ovirt.org/view/ovirt_node/job/ovirt-node-iso-devel/2701/

Test with above build, this issue has been fixed, ovirt can output the correct info when view all diagnostic utilities in Diagnostic page.
Comment 8 cshao 2013-10-24 06:06:48 EDT
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

RHEV-H can output the correct info when view all diagnostic utilities in Diagnostic page.

So the bug is fixed, change bug status to VERIFIED.
Comment 10 Cheryn Tan 2013-11-07 19:26:12 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 errata-xmlrpc 2014-01-21 14:42:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.