Bug 980374 - Error after logout and login
Error after logout and login
Status: CLOSED DUPLICATE of bug 961788
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexandre Porcelli
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 04:05 EDT by Eva Kopalova
Modified: 2016-06-17 17:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 16:03:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-4091 Major Resolved Error logging out 2013-08-24 01:41:53 EDT

  None (edit)
Description Eva Kopalova 2013-07-02 04:05:12 EDT
Description of problem:
The application fails to load with JBWEB000066: Exception report reported in the browser (firefox 21.0)


Version-Release number of selected component (if applicable):
DR5

How reproducible:


Steps to Reproduce:
1. open business central
2. login (i was using my own account; not the pre-set one)
3. logout
4. in the same browser tab, try to log in.

Actual results:
* stacktrace in the console:
09:55:52,231 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/business-central].[ErraiServlet]] (http-/127.0.0.1:8080-5) JBWEB000236: Servlet.service() for servlet ErraiServlet threw exception: java.lang.RuntimeException: bad payload
	at org.jboss.errai.bus.server.io.MessageFactory.createCommandMessage(MessageFactory.java:104) [errai-bus-2.3.1.Final.jar:2.3.1.Final]
	at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:117) [errai-bus-2.3.1.Final.jar:2.3.1.Final]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:832) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:620) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:553) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]

* error in the web browser
JBWEB000065: HTTP Status 500 - org.uberfire.security.auth.AuthenticationException: Validation fails.

Expected results:
login is successful after logout even if in the same browser tab.

Additional info:
Note that this is ok as soon as you open a new tab...however, you apparently remained logged in as user credentials are not requested. it seems like this is related to https://bugzilla.redhat.com/show_bug.cgi?id=956546
Comment 1 Lukáš Petrovický 2013-07-02 04:21:17 EDT
Also possibly duplicate with bug 961788.
Comment 3 Rajesh Rajasekaran 2013-08-01 16:03:40 EDT

*** This bug has been marked as a duplicate of bug 961788 ***
Comment 4 JBoss JIRA Server 2013-08-23 21:08:18 EDT
Alexandre Porcelli <porcelli@redhat.com> updated the status of jira JBPM-4091 to Resolved

Note You need to log in before you can comment on or make changes to this bug.