Bug 980389 - preunsintall script of openstack-quantum-openvswitch.noarch needs to disable/stop quantum-ovs-cleanup.service
preunsintall script of openstack-quantum-openvswitch.noarch needs to disable/...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: async
: 3.0
Assigned To: Terry Wilson
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 04:50 EDT by Alan Pevec
Modified: 2016-04-26 13:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.2-4.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 980292
Environment:
Last Closed: 2013-07-10 11:42:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2013-07-02 04:50:27 EDT
Same issue with quantum-ovs-cleanup sysv initscript in openstack-quantum-2013.1.2-3.el6

+++ This bug was initially created as a clone of Bug #980292 +++

Description of problem:

preunsintall scriptlet of openstack-quantum-openvswitch disable/stop only quantum-openvswitch-agent.service as below:

======
# rpm -q --scripts openstack-quantum-openvswitch.noarch
preuninstall scriptlet (using /bin/sh):
if [ $1 -eq 0 ] ; then
    # Package removal, not upgrade
    /bin/systemctl --no-reload disable quantum-openvswitch-agent.service > /dev/null 2>&1 || :
    /bin/systemctl stop quantum-openvswitch-agent.service > /dev/null 2>&1 || :
fi
postuninstall scriptlet (using /bin/sh):
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
if [ $1 -ge 1 ] ; then
    # Package upgrade, not uninstall
    /bin/systemctl try-restart quantum-openvswitch-agent.service >/dev/null 2>&1 || :
fi

======

But this package provides quantum-ovs-cleanup.service, too. So it should disable/stop this, too, in preunstall scriptlet.


Without it, when you reinstall openstack-quantum-openvswitch, quantum-ovs-cleanup.service fails to start.

1) enable/start quantum-ovs-cleanup.service.
# systemctl enable quantum-ovs-cleanup.service
# systemctl start quantum-ovs-cleanup.service 

2) Reinstall openstack-quantum-openvswitch.
# yum remove openstack-quantum-openvswitch
# yum install openstack-quantum-openvswitch

3) quantum-ovs-cleanup.service fails to start.
# systemctl start quantum-ovs-cleanup.service 
Failed to issue method call: Unit quantum-ovs-cleanup.service failed to load: No such file or directory. See system logs and 'systemctl status quantum-ovs-cleanup.service' for details.


Version-Release number of selected component (if applicable):

# rpm -q openstack-quantum-openvswitch
openstack-quantum-openvswitch-2012.2.3-2.fc18.noarch
Comment 1 Alan Pevec 2013-07-02 06:10:19 EDT
> Same issue with quantum-ovs-cleanup sysv initscript in
> openstack-quantum-2013.1.2-3.el6

openstack-quantum-2013.1.2-3.el6ost that is
Comment 4 errata-xmlrpc 2013-07-10 11:42:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1020.html

Note You need to log in before you can comment on or make changes to this bug.