Bug 980452 - It reports an error when select Keyboard and Performance through ssh using wireless
It reports an error when select Keyboard and Performance through ssh using wi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 08:10 EDT by wanghui
Modified: 2014-01-21 14:43 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
An error in the UI was being reported when selecting Keyboard and Performance through ssh selecting wireless network. This happened because the UI encountered difficulties when the encoding of the console got changed.Now the UI always uses UTF-8, so this error no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16554 None None None Never

  None (edit)
Description wanghui 2013-07-02 08:10:40 EDT
Description of problem:
It reports an error when you select Keyboard and Performance through ssh using wireless.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh6.5
2. Connect the IPv4 network using dhcp mode.
3. SSH to the rhevh6.5 using a host which network is wireless.
4. Select the keyboard and Performance.


Actual results:
After step4, it will reports that an error appeared in the UI etc.

Expected results:
After step4, the Keyboard and Performance can be selected.

Additional info:
Comment 2 Mike Burns 2013-07-02 08:24:18 EDT
Can you please provide information on the errors seen?  logs, screenshots, error messages?
Comment 3 wanghui 2013-07-02 08:35:46 EDT
The following is the messages in screenshots.And there is no error logs in ovirt.log.

An error appeared in the UI: UnicodeEncodeError('ascii', u'\u25b2', 0, 1, 'ordinal not in range(128)')
Press ENTER to logout ...
or enter 's' to drop to shell
Comment 4 Fabian Deutsch 2013-07-08 08:23:09 EDT
This could be the same cause as in bug 980371


Could you try the build given in bug 980371 comment 5 ?
Comment 5 wanghui 2013-07-08 23:21:37 EDT
Test bulid:
rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso
ovirt-node-3.0.0-2.999.20130708020233git0792892.el6.noarch

Test steps:
1. Install rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso
2. Connect the IPv4 network using dhcp mode.
3. SSH to the host using a host which network is wireless.
4. Select the keyboard and Performance.

Actual results:
After step4, it can select the keyboard and Performance.

It is fixed in the build rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso.
Comment 6 Fabian Deutsch 2013-07-09 07:29:01 EDT
(In reply to wanghui from comment #5)
> Test bulid:
> rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso
> ovirt-node-3.0.0-2.999.20130708020233git0792892.el6.noarch
> 
> Test steps:
> 1. Install rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso
> 2. Connect the IPv4 network using dhcp mode.
> 3. SSH to the host using a host which network is wireless.
> 4. Select the keyboard and Performance.
> 
> Actual results:
> After step4, it can select the keyboard and Performance.
> 
> It is fixed in the build rhev-hypervisor6-6.5-20130222.0.auto1716.el6.iso.

That's nice Wang, thanks.

Fixed in http://gerrit.ovirt.org/16554
Comment 9 wanghui 2013-07-21 23:44:00 EDT
Test bulid:
rhev-hypervisor6-6.5-20130222.0.auto1744.el6.noarch.rpm
ovirt-node-3.0.0-999.0.20130719134242gitb6ab8be.el6.noarch

Test steps:
1. Install rhev-hypervisor6-6.5-20130222.0.auto1744.el6.iso
2. Connect the IPv4 network using dhcp mode.
3. SSH to the host using a host which network is wireless.
4. Select the keyboard and Performance.

Actual results:
After step4, it can select the keyboard and Performance.

It is fixed in the build rhev-hypervisor6-6.5-20130222.0.auto1744.el6.iso. So change the status from ON_QA to VERIFIED.
Comment 10 wanghui 2013-07-21 23:51:58 EDT
Change it back to on-qa,because there is no official build now.
I will verify this bug when official build on brewweb is ready.
Comment 11 wanghui 2013-08-01 22:08:08 EDT
Test bulid:
rhev-hypervisor6-6.5-20130725.0.el6
ovirt-node-3.0.0-6.1.el6.noarch

Test steps:
1. Install rhev-hypervisor6-6.5-20130222.0.auto1744.el6.iso
2. Connect the IPv4 network using dhcp mode.
3. SSH to the host using a host which network is wireless.
4. Select the keyboard and Performance.

Actual results:
After step4, it can select the keyboard and Performance.

It is fixed in the build rhev-hypervisor6-6.5-20130725.0.el6. So change the status from ON_QA to VERIFIED.

Thanks.
Comment 15 Cheryn Tan 2013-11-07 19:36:56 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 17 errata-xmlrpc 2014-01-21 14:43:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.