Bug 980557 - Fix missing python uuid module in ha_tests.py on python 2.4
Fix missing python uuid module in ha_tests.py on python 2.4
Status: CLOSED DUPLICATE of bug 953208
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Alan Conway
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 13:22 EDT by Alan Conway
Modified: 2013-10-18 10:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 10:17:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2013-07-02 13:22:56 EDT
Description of problem: HA tests failing on older python (2.4) with message like this:

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/qpid-cpp-0.18-mrg/label/rhel5-64/qpid/cpp/cpp-vpath/src/tests/../../../src/tests/ha_tests.py", line 26, in ?
    from ha_test import *
  File "/var/lib/jenkins/workspace/qpid-cpp-0.18-mrg/label/rhel5-64/qpid/cpp/src/tests/ha_test.py", line 29, in ?
    from uuid import UUID
ImportError: No module named uuid
FAIL: run_ha_tests

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce: run_python_tests

Actual results: fail with message above.


Expected results: pass


Additional info:
Comment 1 Alan Conway 2013-07-02 13:29:45 EDT
Forgot to mention in description - this applies to the 0.18-mrg branch.

Fix on branch 0.18-mrg-aconway-bz980557

http://git.app.eng.bos.redhat.com/?p=rh-qpid.git;a=commit;h=d784c49a7ac9981563c899de23c75014f8235233
Comment 2 Mike Cressman 2013-10-18 10:17:17 EDT

*** This bug has been marked as a duplicate of bug 953208 ***

Note You need to log in before you can comment on or make changes to this bug.