Bug 980572 - new yum importer fails to import groups from fedora 18 repo
new yum importer fails to import groups from fedora 18 repo
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
: 979454 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 14:16 EDT by Michael Hrivnak
Modified: 2013-09-10 11:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:44:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hrivnak 2013-07-02 14:16:59 EDT
Run this:

pulp-admin rpm repo create --repo-id=f18 --relative-url=f18 --feed=http://dl.fedoraproject.org/pub/fedora/linux/releases/18/Everything/x86_64/os/ --skip=rpm,drpm,distribution

... and do a sync. It will fail with output of "unexpected error". Looking in the logs, the importer is failing to properly parse the XML in comps.xml. Note that there is no documentation of what that file should contain, so we're playing it by ear. The importer is currently expecting to find something that apparently is optional.
Comment 1 Michael Hrivnak 2013-07-02 16:18:05 EDT
https://github.com/pulp/pulp_rpm/pull/268
Comment 2 Jeff Ortel 2013-07-03 18:11:15 EDT
build: 2.2.0-18.beta
Comment 3 Jeff Ortel 2013-07-03 18:14:52 EDT
Correction:

build: 2.2.0-0.18.beta
Comment 4 Preethi Thomas 2013-07-09 12:50:53 EDT
verfied that repogroups are synced
[root@ibm-x3550m3-11 ~]# rpm -qa |grep pulp-server
pulp-server-2.2.0-0.19.beta.fc18.noarch
[root@ibm-x3550m3-11 ~]# 

[root@ibm-x3550m3-11 ~]# pulp-admin rpm repo list
+----------------------------------------------------------------------+
                            RPM Repositories
+----------------------------------------------------------------------+

Id:                  test
Display Name:        test
Description:         None
Content Unit Counts: 

Id:                  zoo
Display Name:        zoo
Description:         None
Content Unit Counts: 
  Erratum:          4
  Package Category: 1
  Package Group:    2
  Rpm:              32

Id:                  test1
Display Name:        test1
Description:         None
Content Unit Counts: 

Id:                  foo
Display Name:        foo
Description:         None
Content Unit Counts: 

Id:                  foreman
Display Name:        foreman
Description:         None
Content Unit Counts: 
  Package Group: 1
  Rpm:           157

Id:                  rhel6-2
Display Name:        rhel6-2
Description:         None
Content Unit Counts: 
  Erratum:                1048
  Package Category:       10
  Package Group:          202
  Rpm:                    7281
  Yum Repo Metadata File: 1

Id:                  f18
Display Name:        f18
Description:         None
Content Unit Counts: 
  Distribution:     1
  Package Category: 12
  Package Group:    97
  Rpm:              4165


[root@ibm-x3550m3-11 ~]#
Comment 5 Michael Hrivnak 2013-07-12 14:42:26 EDT
*** Bug 979454 has been marked as a duplicate of this bug. ***
Comment 6 Preethi Thomas 2013-09-10 11:44:19 EDT
2.2 released
http://repos.fedorapeople.org/repos/pulp/pulp/stable/2.2/

Note You need to log in before you can comment on or make changes to this bug.