Bug 980588 - SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin/java from 'write' accesses on the directory publish.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:53d7944b0d06c17bef98effc1e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 15:21 EDT by Dean Hunter
Modified: 2013-07-08 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 09:20:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Hunter 2013-07-02 15:21:36 EDT
Description of problem:
This alert occurred during ipa-server-install.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin/java from 'write' accesses on the directory publish.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that java should be allowed write access on the publish directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:pki_tomcat_t:s0
Target Context                system_u:object_r:cert_t:s0
Target Objects                publish [ dir ]
Source                        java
Source Path                   /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jr
                              e/bin/java
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           java-1.7.0-openjdk-1.7.0.25-2.3.10.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-57.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-02 13:44:03 CDT
Last Seen                     2013-07-02 13:44:03 CDT
Local ID                      5e9e72d0-4baa-418a-b7f1-67399a5ed908

Raw Audit Messages
type=AVC msg=audit(1372790643.281:878): avc:  denied  { write } for  pid=4970 comm="java" name="publish" dev="dm-1" ino=394452 scontext=system_u:system_r:pki_tomcat_t:s0 tcontext=system_u:object_r:cert_t:s0 tclass=dir


type=SYSCALL msg=audit(1372790643.281:878): arch=x86_64 syscall=open success=no exit=EACCES a0=7f994c003610 a1=241 a2=1b6 a3=7473614d2f687369 items=0 ppid=1 pid=4970 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=java exe=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin/java subj=system_u:system_r:pki_tomcat_t:s0 key=(null)

Hash: java,pki_tomcat_t,cert_t,dir,write

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Dean Hunter 2013-07-08 09:20:41 EDT
The problem is resolved with selinux-policy-3.12.1-59.fc19.noarch.

Note You need to log in before you can comment on or make changes to this bug.