Bug 980606 - Error starting domain: operation failed: Unable to create macvlan device
Error starting domain: operation failed: Unable to create macvlan device
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 16:30 EDT by Chris Murphy
Modified: 2013-08-31 13:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 13:16:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-07-02 16:30:40 EDT
Description of problem:
When Source device is set to: "Host device lo: macvtap" this message occurs when starting the VM.



Version-Release number of selected component (if applicable):
virt-manager-0.10.0-1.fc19.noarch
qemu-system-x86-1.4.2-4.fc19.x86_64
libvirt-daemon-driver-qemu-1.0.5.2-1.fc19.x86_64
qemu-kvm-1.4.2-4.fc19.x86_64
qemu-common-1.4.2-4.fc19.x86_64
qemu-img-1.4.2-4.fc19.x86_64
qemu-guest-agent-1.4.2-4.fc19.x86_64
kernel 3.10.0-1.fc20.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Create a VM with a NIC whose option Source device: is set to "Host device lo: macvtap"
2. Start the VM

Actual results:
Error. VM doesn't start.

Expected results:
No error, VM starts.

Regression:
If I change the Source device: option to "Host device p5p1: macvtap" this problem doesn't occur.

Additional info:
Error starting domain: operation failed: Unable to create macvlan device

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1210, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 698, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: operation failed: Unable to create macvlan device
Comment 1 Cole Robinson 2013-08-31 13:16:02 EDT
Thanks for the report, 'lo' isn't expected to work with macvtap, so virt-manager shouldn't be showing it. Pushed a fix upstream:

commit 2c918ecaa6700dac5835dda16d6a2b1f97aa1e44
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sat Aug 31 13:14:32 2013 -0400

    uihelpers: Don't list 'lo' as a macvtap interface (bz #980606)

Since this is pretty minor, just closing as UPSTREAM

Note You need to log in before you can comment on or make changes to this bug.