Bug 980609 - storage test ignores choice of disk to test
storage test ignores choice of disk to test
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 980612
  Show dependency treegraph
 
Reported: 2013-07-02 16:46 EDT by Greg Nichols
Modified: 2013-08-06 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client-1.6.4-57
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 980612 (view as bug list)
Environment:
Last Closed: 2013-08-06 13:52:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage test patch fixing logic around choice of disk to test (484 bytes, patch)
2013-07-02 17:09 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-07-02 16:46:45 EDT
Description of problem:

When the storage test is run interactively, and the user is allowed to choose between multiple disks to test, the users choice is ignored.

Example:

Host bus adapter host0 has storage devices sda, sda1, sda2, sda3
Which disk would you like to test:  (sda|sda1|sda2|sda3|all) sda1
[...]
Found sda in /proc/partitions.
Error: sda is currently in use by LVM.
It cannot be tested. You may need to reinstall.
FAIL


Version-Release number of selected component (if applicable):

hwcert-client version 1.6.4, release 56
Comment 1 Greg Nichols 2013-07-02 17:09:50 EDT
Created attachment 767980 [details]
storage test patch fixing logic around choice of disk to test
Comment 4 errata-xmlrpc 2013-08-06 13:52:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1139.html

Note You need to log in before you can comment on or make changes to this bug.