Bug 98064 - xemacs segfaults every time
xemacs segfaults every time
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 18:14 EDT by Dario Landazuri
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 03:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb backtrace output (1.50 KB, text/plain)
2003-06-25 18:15 EDT, Dario Landazuri
no flags Details

  None (edit)
Description Dario Landazuri 2003-06-25 18:14:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

Description of problem:
I'm not sure how much more detail I can give.  Whenever I try to launch/run
xemacs, it makes like it's loading for a minute, then segfaults.  I actually get
a xemacs window, and see it loading some el files before it dies.  I'll attach a
backtrace below.

Version-Release number of selected component (if applicable):
xemacs-21.4.12-6

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal
2. Type "xemacs"
3. Wait, watch it segfault
    

Actual Results:  Segmentation Fault

Expected Results:  Pretty Xemacs window to edit text in. :)

Additional info:
Comment 1 Dario Landazuri 2003-06-25 18:15:53 EDT
Created attachment 92622 [details]
gdb backtrace output
Comment 2 Jens Petersen 2003-07-07 22:26:23 EDT
What if you run:

  a) xemacs -q
  b) xemacs -nw
  c) xemacs -vanilla

Do any of those give you more luck?
Comment 3 Dario Landazuri 2003-07-08 09:59:30 EDT
a) and b) still segfault.  c) works.

Do you want backtraces from a) and b)?

Thanks,
Dario
Comment 4 Jens Petersen 2003-07-09 01:31:06 EDT
Well this suggests the problem occurs because of your site lisp files.
Comment 5 Dario Landazuri 2003-07-16 12:32:05 EDT
I'm sorry, but I don't know what I should be looking at to fix.  These are all
part of the xemacs package, and I haven't made any changes to them. 
Comment 6 Jens Petersen 2003-07-16 22:27:26 EDT
"-vanilla" is the same as "-q -no-site-file -no-early-packages".

Could you try

i) xemacs -q -no-site-file

and

ii) xemacs -q -no-early-packages

to see if any of those work.

Also how about

iii) LANG=C xemacs -q

say?
Comment 7 Dario Landazuri 2003-07-17 09:59:33 EDT
i) works, ii) segfaults, and iii) works.

I've been trying to pay attention and see which .el file it seems to have
problems on, and it looks like it's always having problems on psgml-init.el.  I
dunno if that'd be helpful at all.

I also checked my default LANG variable, and it's set to en_US.UTF-8.

Thanks for your help.
Comment 8 Jens Petersen 2003-07-21 23:30:19 EDT
Do you have any private elisp packages under "~/.xemacs/"?

eg in "~/.xemacs/xemacs/packages/lisp/"
Comment 9 Dario Landazuri 2003-07-22 11:01:00 EDT
I don't have a ~/.xemacs directory at all.
Comment 10 Jens Petersen 2003-07-22 11:17:33 EDT
And "xemacs -no-early-packages" segfaults too?

Perhaps you could try the latest xemacs and xemacs-sumo package in rawhide
to see if you can still reproduce the problem there.  (If you want to run it
on RHL 9, you'll need to rebuild it from the srpm because of library version
differences.)
Comment 11 Jens Petersen 2003-11-07 03:15:56 EST
Closing for now.

Note You need to log in before you can comment on or make changes to this bug.