Bug 980710 - chrony not installed by default; Network Time in gnome-control-center therefore broken
chrony not installed by default; Network Time in gnome-control-center therefo...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 01:39 EDT by Michael Catanzaro
Modified: 2014-03-16 23:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 22:27:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Catanzaro 2013-07-03 01:39:57 EDT
I installed F19 using the installation DVD. For software sources, I selected GNOME desktop with a few addons (Epiphany, games, dev tools).

chrony was not installed. The NTP toggle in gnome-control-center Time & Date panel is broken (you can press it but it doesn't work and will reset itself the next time you visit) and timedatectl fails to set NTP.

Everything works after installing chrony manually.

chrony was installed by default in F18; I wonder what changed. I also wonder what the best way to fix this would be, without requiring any user intervention.
Comment 1 Bill Nottingham 2013-07-09 12:10:43 EDT
It used to be installed conditional on the installation of system-config-date.; since that's not part of GNOME any more, it's not pulled in.

I've fixed this in the metadata for F-20; we could pull back the fix to F-19.
Comment 2 Bill Nottingham 2013-07-09 15:27:28 EDT
... and done for F19 too.
Comment 3 Michael Catanzaro 2013-11-22 22:27:31 EST
I guess this can be closed?

Note You need to log in before you can comment on or make changes to this bug.