Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980713 - [origin_runtime_157] psql client version is still 8.4 after embeded postgresql-9.2 to scalable app
Summary: [origin_runtime_157] psql client version is still 8.4 after embeded postgresq...
Keywords:
Status: CLOSED DUPLICATE of bug 980753
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Hiro Asari
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-03 06:02 UTC by Yan Du
Modified: 2015-05-14 23:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-03 13:36:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yan Du 2013-07-03 06:02:38 UTC
Description of problem:
create a app embeded postgresql-9.2, and ssh in to the all, run psql or psql --version


Version-Release number of selected component (if applicable):
devenv_3441
rhc-1.11.2


How reproducible:
Always


Steps to Reproduce:

1. Create an app and added postgresql-9.2 to the app
$ rhc app create j7s jbossas-7 -s
$ rhc cartridge add -a j7s -c postgresql-9.2

2. ssh the app and run psq or psql --version
$ psql --version
$ psql


Actual results:
[j7s-111.dev.rhcloud.com 574972695356251140259840]\> psql --version
psql (PostgreSQL) 8.4.13
contains support for command-line editing

[j7s-111.dev.rhcloud.com 574972695356251140259840]\> psql
psql (8.4.13, server 9.2.4)
WARNING: psql version 8.4, server version 9.2.
         Some psql features might not work.
Type "help" for help.



Expected results:
should show psql (PostgreSQL) 9.2.4



Additional info:
It is ok with devenv_3439
[j7-111.dev.rhcloud.com 181535259818370384527360]\> psql --version
psql (PostgreSQL) 9.2.4


[j7-111.dev.rhcloud.com 181535259818370384527360]\> psql
psql (9.2.4)
Type "help" for help.

Comment 1 Yan Du 2013-07-03 10:40:17 UTC
clarify the Additional info:

Issue only occured with scablable app. both in devenv_3439 and devenv_3441.
It works normally with non-scalable app.

[p33-111.dev.rhcloud.com 51d3f17048d5f979c1000002]\> psql
psql (9.2.4)
Type "help" for help.

Comment 2 Hiro Asari 2013-07-03 13:36:13 UTC
This is essentially the same issue as #980753. You are not connecting to the correct gear to look at the DB environment. There should be a way to do this easily.

*** This bug has been marked as a duplicate of bug 980753 ***


Note You need to log in before you can comment on or make changes to this bug.