Bug 980722 - Print entries in cb buffer in FIFO order
Print entries in cb buffer in FIFO order
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: vsomyaju
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 02:40 EDT by vsomyaju
Modified: 2015-03-04 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.18rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:35:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vsomyaju 2013-07-03 02:40:03 EDT
Description of problem:

Currently cb buffer was being printed in LIFO order, which
is was against the percieved notion of logs having older
entries printed before newer entries in the state dumps.

Upstream bug for this is: https://bugzilla.redhat.com/show_bug.cgi?id=966847

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create distribute-replicate volume
2. Take Statedumps
3. Print State Dumps

Actual results:
It prints in LIFO order

Expected results:
Print it in FIFO order.

Additional info:
Comment 2 Amar Tumballi 2013-08-11 07:25:02 EDT
https://code.engineering.redhat.com/gerrit/9633
Comment 3 Sachidananda Urs 2013-08-20 05:50:39 EDT
Tested on: glusterfs 3.4.0.20rhs built on Aug 14 2013 09:04:38

Verified!
Comment 4 Scott Haines 2013-09-23 18:35:40 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.