Bug 980759 - Python-docutils rebuild fails with Python 3.3.2
Python-docutils rebuild fails with Python 3.3.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-docutils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 03:58 EDT by Matej Stuchlik
Modified: 2016-01-31 21:15 EST (History)
2 users (show)

See Also:
Fixed In Version: python-docutils-0.11-0.1.20130715svn7687.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 20:35:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for sourceforge.net/p/docutils/bugs/235/ (1.15 KB, patch)
2013-07-03 04:00 EDT, Matej Stuchlik
no flags Details | Diff
fix for sourceforge.net/p/docutils/bugs/210/ (1.88 KB, patch)
2013-07-03 04:00 EDT, Matej Stuchlik
no flags Details | Diff
spec changes (817 bytes, patch)
2013-07-03 04:01 EDT, Matej Stuchlik
no flags Details | Diff
rebase to r7687 (2.62 KB, patch)
2013-07-15 03:08 EDT, Matej Stuchlik
no flags Details | Diff

  None (edit)
Description Matej Stuchlik 2013-07-03 03:58:40 EDT
Python-docutils fails to build in Fedora 19 due to changes in Python 3.3.2[1] and the csv module[2].

I took the liberty of preparing the patches: test-tables-quotes.patch for [1], docutils-strict-csv-parser.patch for [2] and finally spec.patch.

Should you deem this worthy of being accepted I wonder if mayhap I could get commit rights and amend this myself? :) Python-docutils is important for our team, I am told, and being able to fix things quickly would be of some benefit.

[1] http://sourceforge.net/p/docutils/bugs/235/
[2] http://sourceforge.net/p/docutils/bugs/210/
Comment 1 Matej Stuchlik 2013-07-03 04:00:07 EDT
Created attachment 768125 [details]
fix for sourceforge.net/p/docutils/bugs/235/
Comment 2 Matej Stuchlik 2013-07-03 04:00:52 EDT
Created attachment 768126 [details]
fix for sourceforge.net/p/docutils/bugs/210/
Comment 3 Matej Stuchlik 2013-07-03 04:01:38 EDT
Created attachment 768127 [details]
spec changes
Comment 4 Toshio Ernie Kuratomi 2013-07-03 11:57:45 EDT
I'd love to have a comaintainer who can care for python3 issues.  However, for your two patches it looks like upstream made some changes when they committed them.  We should go with what's in upstream's svn repository instead of what was posted to the bug tracker.

When upstream doesn't have links to the commit that added the patch we should probably have those in addition to the link to the bug tracker in the spec file (part of this is just that sourceforge is a pain to get information out of but the second bug doesn't have a commit attached).

One other note -- For the docutils package, we rebase to snapshots from the current svn tree more often than other packages.  This is just because of the nature of how upstream develops, fixes, and makes releases.  It may be time for us to make a new snapshot that pulls in all of these changes.  If you'd like to prepare a new docutils package based on a snapshot, that would also be a suitable approach for me to review that spec file diff with a view towards giving you commit.
Comment 5 Matej Stuchlik 2013-07-04 04:40:31 EDT
(In reply to Toshio Ernie Kuratomi from comment #4)
> One other note -- For the docutils package, we rebase to snapshots from the
> current svn tree more often than other packages.  This is just because of
> the nature of how upstream develops, fixes, and makes releases.  It may be
> time for us to make a new snapshot that pulls in all of these changes.  If
> you'd like to prepare a new docutils package based on a snapshot, that would
> also be a suitable approach for me to review that spec file diff with a view
> towards giving you commit.

Sounds like a plan! I'll look into it.
Comment 6 Matej Stuchlik 2013-07-15 03:08:48 EDT
Created attachment 773570 [details]
rebase to r7687
Comment 7 Matej Stuchlik 2013-07-15 03:11:16 EDT
I've added the patch, hope it's fine. :)
Comment 8 Toshio Ernie Kuratomi 2013-07-15 10:48:16 EDT
I noticed you removed one of the comments for disabling a test -- I assume you also removed the part of the patch that was disabling that test?
Comment 9 Toshio Ernie Kuratomi 2013-07-15 10:49:37 EDT
Also, go ahead and apply for comaintainership and I'll approve you here: https://admin.fedoraproject.org/pkgdb/acls/name/python-setuptools
Comment 10 Toshio Ernie Kuratomi 2013-07-15 11:18:16 EDT
Oops, sorry -- too many windows open in my browser.  This is the correct pkgdb link: https://admin.fedoraproject.org/pkgdb/acls/name/python-docutils
Comment 11 Matej Stuchlik 2013-07-15 14:37:11 EDT
(In reply to Toshio Ernie Kuratomi from comment #8)
> I noticed you removed one of the comments for disabling a test -- I assume
> you also removed the part of the patch that was disabling that test?

Indeed I did!

> Oops, sorry -- too many windows open in my browser.  This is the correct pkgdb > link: https://admin.fedoraproject.org/pkgdb/acls/name/python-docutils

Done. I hope, at least, that page always seems to eagerly do just what I don't want it to do.
Comment 12 Toshio Ernie Kuratomi 2013-07-15 15:45:01 EDT
Cool.  You're now a comaintainer.  Feel free to push the fix/update and build :-)
Comment 13 Fedora Update System 2013-07-16 06:22:00 EDT
python-docutils-0.11-0.1.20130715svn7687.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-docutils-0.11-0.1.20130715svn7687.fc19
Comment 14 Fedora Update System 2013-07-16 23:07:27 EDT
Package python-docutils-0.11-0.1.20130715svn7687.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-docutils-0.11-0.1.20130715svn7687.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13083/python-docutils-0.11-0.1.20130715svn7687.fc19
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-07-25 20:35:39 EDT
python-docutils-0.11-0.1.20130715svn7687.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.