Bug 980768 - Traceback detected while installing vdsm using Big Bend ISO.
Traceback detected while installing vdsm using Big Bend ISO.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Bala.FA
Sudhir D
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:16 EDT by Gowrishankar Rajaiyan
Modified: 2015-05-13 12:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-22.7.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:32:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2013-07-03 04:16:21 EDT
Description of problem: Looks like we are seeing bug 893065 in our ISO. Filing it here since I detected this while installing Big Bend.


Version-Release number of selected component (if applicable):
RHS-2.1-20130630.n.0/2/RHS/x86_64/os/RHS

How reproducible: Always


Steps to Reproduce:
1. Installed using beaker PXE provisioning.
2. After successful installation, observe install.log


Actual results:
Installing vdsm-4.10.2-22.5.el6rhs.x86_64
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 143, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 125, in main
    load_modules()
  File "/usr/bin/vdsm-tool", line 74, in load_modules
    module = imp.load_module(mod_name, mod_fobj, mod_absp, mod_desc)
  File "/usr/lib64/python2.6/site-packages/vdsm/tool/seboolsetup.py", line 21, in <module>
    import seobject
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 959, in <module>
    class portRecords(semanageRecords):
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 960, in portRecords
    valid_types = get_valid_types("port_type")
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 202, in get_valid_types
    valid_types =  setools.seinfo(setools.ATTRIBUTE,selinux_class_type)[0]["types"]
  File "/usr/lib64/python2.6/site-packages/setools/__init__.py", line 49, in seinfo
    dict_list = _seinfo.seinfo(setype, name)
RuntimeError: No default policy found.
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 143, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 125, in main
    load_modules()
  File "/usr/bin/vdsm-tool", line 74, in load_modules
    module = imp.load_module(mod_name, mod_fobj, mod_absp, mod_desc)
  File "/usr/lib64/python2.6/site-packages/vdsm/tool/seboolsetup.py", line 21, in <module>
    import seobject
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 959, in <module>
    class portRecords(semanageRecords):
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 960, in portRecords
    valid_types = get_valid_types("port_type")
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 202, in get_valid_types
    valid_types =  setools.seinfo(setools.ATTRIBUTE,selinux_class_type)[0]["types"]
  File "/usr/lib64/python2.6/site-packages/setools/__init__.py", line 49, in seinfo
    dict_list = _seinfo.seinfo(setype, name)
RuntimeError: No default policy found.
warning: %post(vdsm-4.10.2-22.5.el6rhs.x86_64) scriptlet failed, exit status 1


Additional info:
Comment 1 Gowrishankar Rajaiyan 2013-07-03 04:18:17 EDT
Works fine when you re-install just the vdsm package.

[root@rhsauto001 ~]# yum erase vdsm
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id, protectbase, security, subscription-
              : manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package vdsm.x86_64 0:4.10.2-22.5.el6rhs will be erased
--> Processing Dependency: vdsm = 4.10.2-22.5.el6rhs for package: vdsm-gluster-4.10.2-22.5.el6rhs.noarch
--> Processing Dependency: vdsm = 4.10.2-22.5.el6rhs for package: vdsm-reg-4.10.2-22.5.el6rhs.noarch
--> Running transaction check
---> Package vdsm-gluster.noarch 0:4.10.2-22.5.el6rhs will be erased
---> Package vdsm-reg.noarch 0:4.10.2-22.5.el6rhs will be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================
 Package                        Arch                     Version                                 Repository                                                            Size
============================================================================================================================================================================
Removing:
 vdsm                           x86_64                   4.10.2-22.5.el6rhs                      @anaconda-InstallationRepo-201306302303.x86_64/2.1                   2.5 M
Removing for dependencies:
 vdsm-gluster                   noarch                   4.10.2-22.5.el6rhs                      @anaconda-InstallationRepo-201306302303.x86_64/2.1                   174 k
 vdsm-reg                       noarch                   4.10.2-22.5.el6rhs                      @anaconda-InstallationRepo-201306302303.x86_64/2.1                   199 k

Transaction Summary
============================================================================================================================================================================
Remove        3 Package(s)

Installed size: 2.9 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing    : vdsm-gluster-4.10.2-22.5.el6rhs.noarch                                                                                                                   1/3 
  Erasing    : vdsm-reg-4.10.2-22.5.el6rhs.noarch                                                                                                                       2/3 
  Erasing    : vdsm-4.10.2-22.5.el6rhs.x86_64                                                                                                                           3/3 
saslpasswd2: user not found
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
  Verifying  : vdsm-4.10.2-22.5.el6rhs.x86_64                                                                                                                           1/3 
  Verifying  : vdsm-reg-4.10.2-22.5.el6rhs.noarch                                                                                                                       2/3 
  Verifying  : vdsm-gluster-4.10.2-22.5.el6rhs.noarch                                                                                                                   3/3 

Removed:
  vdsm.x86_64 0:4.10.2-22.5.el6rhs                                                                                                                                          

Dependency Removed:
  vdsm-gluster.noarch 0:4.10.2-22.5.el6rhs                                               vdsm-reg.noarch 0:4.10.2-22.5.el6rhs                                              

Complete!
[root@rhsauto001 ~]# 
[root@rhsauto001 ~]# 


[root@rhsauto001 ~]# yum install vdsm vdsm-gluster vdsm-reg
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id, protectbase, security, subscription-
              : manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package vdsm.x86_64 0:4.10.2-22.5.el6rhs will be installed
---> Package vdsm-gluster.noarch 0:4.10.2-22.5.el6rhs will be installed
---> Package vdsm-reg.noarch 0:4.10.2-22.5.el6rhs will be installed
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================
 Package                                  Arch                               Version                                           Repository                              Size
============================================================================================================================================================================
Installing:
 vdsm                                     x86_64                             4.10.2-22.5.el6rhs                                beaker-RHS                             676 k
 vdsm-gluster                             noarch                             4.10.2-22.5.el6rhs                                beaker-RHS                              40 k
 vdsm-reg                                 noarch                             4.10.2-22.5.el6rhs                                beaker-RHS                              66 k

Transaction Summary
============================================================================================================================================================================
Install       3 Package(s)

Total download size: 782 k
Installed size: 2.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): vdsm-4.10.2-22.5.el6rhs.x86_64.rpm                                                                                                            | 676 kB     00:00     
(2/3): vdsm-gluster-4.10.2-22.5.el6rhs.noarch.rpm                                                                                                    |  40 kB     00:00     
(3/3): vdsm-reg-4.10.2-22.5.el6rhs.noarch.rpm                                                                                                        |  66 kB     00:00     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                        19 MB/s | 782 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : vdsm-4.10.2-22.5.el6rhs.x86_64                                                                                                                           1/3 
  Installing : vdsm-reg-4.10.2-22.5.el6rhs.noarch                                                                                                                       2/3 
  Installing : vdsm-gluster-4.10.2-22.5.el6rhs.noarch                                                                                                                   3/3 
  Verifying  : vdsm-4.10.2-22.5.el6rhs.x86_64                                                                                                                           1/3 
  Verifying  : vdsm-reg-4.10.2-22.5.el6rhs.noarch                                                                                                                       2/3 
  Verifying  : vdsm-gluster-4.10.2-22.5.el6rhs.noarch                                                                                                                   3/3 

Installed:
  vdsm.x86_64 0:4.10.2-22.5.el6rhs                     vdsm-gluster.noarch 0:4.10.2-22.5.el6rhs                     vdsm-reg.noarch 0:4.10.2-22.5.el6rhs                    

Complete!
[root@rhsauto001 ~]#
Comment 2 Anthony Towns 2013-07-03 04:28:15 EDT
Is policycoreutils being installed before the first install of vdsm? If not, you may need to add a Requires line to vdsm to ensure it is? Otherwise, don't know, but expect it's a problem in the vdsm package one way or another.
Comment 4 Gowrishankar Rajaiyan 2013-07-03 07:19:56 EDT
(In reply to Anthony Towns from comment #2)
> Is policycoreutils being installed before the first install of vdsm? If not,
> you may need to add a Requires line to vdsm to ensure it is? Otherwise,
> don't know, but expect it's a problem in the vdsm package one way or another.

Looking at the install log[1], policycoreutils does get installed before the first install of vdsm.

[1] https://url.corp.redhat.com/32ab2f8
Comment 5 Daniel Walsh 2013-07-03 07:30:28 EDT
The problem is you have no selinux-policy installed when the commands run.

require selinux-policy-base would probably solve the problem.
Comment 6 Miroslav Grepl 2013-07-03 07:48:53 EDT
If you have installed updated policycoreutils, try to re-install vdsm pkg.
Comment 7 Gowrishankar Rajaiyan 2013-07-03 07:52:56 EDT
selinux-policy-base is missing in ISO[1].

[1] https://url.corp.redhat.com/b496586
Comment 8 Gowrishankar Rajaiyan 2013-07-03 07:54:43 EDT
(In reply to Miroslav Grepl from comment #6)
> If you have installed updated policycoreutils, try to re-install vdsm pkg.

I do not see the issue even with the existing policycoreutils when trying to re-install vdsm pkg. Ref comment #1 for more details.
Comment 9 Daniel Walsh 2013-07-03 08:07:50 EDT
selinux-policy-base is provided by all selinux-policy packages including selinux-policy-targeted.
Comment 10 Bala.FA 2013-07-31 07:00:51 EDT
looks like duplicate of rhbz#963806
Comment 11 Gowrishankar Rajaiyan 2013-08-08 01:50:14 EDT
Verified using build RHS-2.1-20130731.n.1 and vdsm-4.10.2-23.0.1.el6rhs.x86_64

<snip from install.log>
Installing selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
Installing vdsm-4.10.2-23.0.1.el6rhs.x86_64
Installing vdsm-gluster-4.10.2-23.0.1.el6rhs.noarch
Installing dhcp-common-4.1.1-34.P1.el6.x86_64
</snip>
Comment 13 errata-xmlrpc 2014-02-25 02:32:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.