This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 980782 - kernel_irqchip defaults to off instead of on without -machine
kernel_irqchip defaults to off instead of on without -machine
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:41 EDT by Markus Armbruster
Modified: 2014-06-17 23:30 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:53:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2013-07-03 04:41:36 EDT
Description of problem:
Logic error in kvm_irqchip_create(): it defaults machine option
kernel_irqchip to off when no machine options exist, but to on when
any machine options exist.

How reproducible:
Always

Steps to Reproduce:
1. Run qemu-kvm -nodefaults -display none -monitor stdio
2. Monitor command info qtree
3. Run qemu-kvm -nodefaults -display none -monitor stdio -machine ""
4. Monitor command info qtree
5. Run qemu-kvm -nodefaults -display none -monitor stdio -machine "kernel_irqchip=off"
6. Monitor command info qtree


Actual results:
Step 2+6 show 'dev: apic, id ""'.
Step 4 shows 'dev: kvm-apic, id ""'.

Expected results:
Step 6 show 'dev: apic, id ""'.
Step 2+4 show 'dev: kvm-apic, id ""'.

Additional info:
In step 3., any other way to create a machine option without disabling
KVM or setting its kernel_irqchip works, including -usb, -kernel, ...

Bug exists upstream, but can't bite there, because KVM is disabled by
default, and you can't enable it without creating machine options.
Comment 2 Markus Armbruster 2013-07-11 02:36:54 EDT
Fixed upstream in 96bc97e^..c1b71b0.
Comment 3 Markus Armbruster 2013-08-06 09:14:02 EDT
RHEL-6 code is different, and doesn't have the logic error described above.  It does have the crash bugs fixed upstream 96bc97e and 6d4cd40.  Not sure they're worth fixing, as the only known reproducers are rather silly command lines.
Comment 4 Miroslav Rezanina 2013-08-29 07:16:23 EDT
Fix included in qemu-kvm-1.5.3-2.el7
Comment 6 huiqingding 2014-01-22 00:23:54 EST
Reproduce this issue using the following version:
qemu-kvm-1.5.2-4.el7.x86_64
kernel-3.10.0-67.el7.x86_64

Steps to Reproduce:
1. Run qemu-kvm -nodefaults -display none -monitor stdio
2. Monitor command info qtree
3. Run qemu-kvm -nodefaults -display none -monitor stdio -machine ""
4. Monitor command info qtree
5. Run qemu-kvm -nodefaults -display none -monitor stdio -machine "kernel_irqchip=off"
6. Monitor command info qtree


Actual results:
Step2 and step6 show 'dev: apic, id ""'.
Step4 shows 'dev: kvm-apic, id ""'.

Verify this issue using the following version:
qemu-kvm-1.5.3-38.el7.x86_64
kernel-3.10.0-67.el7.x86_64

Steps to Verification:
1. Run qemu-kvm -nodefaults -display none -monitor stdio
2. Monitor command info qtree
3. Run qemu-kvm -nodefaults -display none -monitor stdio -machine ""
4. Monitor command info qtree
5. Run qemu-kvm -nodefaults -display none -monitor stdio -machine "kernel_irqchip=off"
6. Monitor command info qtree

Actual results:
Step 6 show 'dev: apic, id ""'.
Step 2 and Step 4 show 'dev: kvm-apic, id ""'.

Based on the above results, I think this bug has been fixed.
Comment 8 Ludek Smid 2014-06-13 06:53:40 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.