Bug 980783 - Better to disable the function "Kernel Dump" using "NFS/SSH" before configured network
Better to disable the function "Kernel Dump" using "NFS/SSH" before configure...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On: 947406 966343 966498 1040742
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:41 EDT by haiyang,dong
Modified: 2014-01-21 14:43 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
The system was allowing ssh/NFS to be used as a KDump target without a configured network This meant that the KDump configuration failed because no network was available when the user tried to configure a SSH or NFS location. This has been fixed by only allowing the KDump ssh/nfs targets to be configured when the network has been configured beforehand. This means that the user does not run into a situation where the kdump configuration fails because of an unconfigured network
Story Points: ---
Clone Of: 966343
Environment:
Last Closed: 2014-01-21 14:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16423 None None None Never

  None (edit)
Description haiyang,dong 2013-07-03 04:41:39 EDT
+++ This bug was initially created as a clone of Bug #966343 +++

Description of problem:
Clean install ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso,don't configure network,
enter Kernel Dump page , check that still can configure "Kernel Dump" using "NFS/SSH"
but actually, so it's better to disable "NFS/SSH" and show that "Network Down,Configure "Kernel Dump" using "NFS/SSH" Disabled"

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso

How reproducible:
100%

Steps to Reproduce:
1.Clean install ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso
2.Check Kernel Dump page Page 

Actual results:


Expected results:

Additional info:
Comment 2 haiyang,dong 2013-07-03 04:42:58 EDT
Also can reproduce it in rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso,
so need clone it from upstream bug Component to downstream Component in order to also track it in rhev-h
Comment 7 haiyang,dong 2013-10-21 07:35:23 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

When disabled network, it will prompt "Networking is not configured, please configure it before NFS or SSH-based kdump",also it will disable the function "Kernel Dump" using "NFS/SSH" and didn't display these two types in kdump page.

so this bug has been fixed, change the status into "VERIFIED"
Comment 10 Cheryn Tan 2013-11-07 19:38:46 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 Charlie 2013-11-13 21:08:46 EST
Hiya can I ask why it is better to do this? does using some of the options cause issues? Trying to explain for errata text. Thanks
Comment 12 haiyang,dong 2013-11-13 21:19:48 EST
(In reply to Charlie from comment #11)
> Hiya can I ask why it is better to do this? does using some of the options
> cause issues? Trying to explain for errata text. Thanks

Need to set network up to configure kdump success via nfs/ssh, so now we redesign kdump page, if users didn't set network up, hide nfs/ssh items, only allow users configure kdump via local.
Comment 13 Ryan Barry 2013-11-14 08:59:44 EST
To reiterate, we don't even want to present the option to set kdump options which are invalid because there's no valid network configuration, so they're hidden if networking is not configured.
Comment 14 Ryan Barry 2013-12-12 09:18:04 EST
While I agree that changing the notice about networking not being configured to a global notice field would be better, I'm not sure that it's a blocker for this bug, since the current notice implementation works well for this issue.
Comment 15 Fabian Deutsch 2013-12-16 14:21:06 EST
(In reply to Ryan Barry from comment #14)
> While I agree that changing the notice about networking not being configured
> to a global notice field would be better, I'm not sure that it's a blocker
> for this bug, since the current notice implementation works well for this
> issue.

Yes, we can drop the dependency on the global notice field. Which is more an RFE,
Comment 17 errata-xmlrpc 2014-01-21 14:43:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.