Bug 980784 - SELinux is preventing /usr/sbin/ldconfig from 'read' accesses on the lnk_file lib64.
SELinux is preventing /usr/sbin/ldconfig from 'read' accesses on the lnk_file...
Status: CLOSED DUPLICATE of bug 799359
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f6a46f969ddef258a2c86986722...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 04:43 EDT by Paolo Villani
Modified: 2013-07-03 07:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 07:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Villani 2013-07-03 04:43:51 EDT
Description of problem:
After installing vmware desktop 8 tools
SELinux is preventing /usr/sbin/ldconfig from 'read' accesses on the lnk_file lib64.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that ldconfig should be allowed read access on the lib64 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ldconfig_t:s0
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                lib64 [ lnk_file ]
Source                        ldconfig
Source Path                   /usr/sbin/ldconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glibc-2.16-31.fc18.x86_64
Target RPM Packages           filesystem-3.1-2.fc18.x86_64
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.6-200.fc18.x86_64 #1 SMP Thu
                              Jun 13 18:56:55 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-07-03 05:38:41 CEST
Last Seen                     2013-07-03 10:36:53 CEST
Local ID                      2368b54a-c5e6-4594-bf31-8070fd795240

Raw Audit Messages
type=AVC msg=audit(1372840613.301:344): avc:  denied  { read } for  pid=17508 comm="ldconfig" name="lib64" dev="dm-1" ino=2364173 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1372840613.301:344): arch=x86_64 syscall=stat success=no exit=EACCES a0=25e1910 a1=7ffff942d9a0 a2=7ffff942d9a0 a3=7 items=0 ppid=10631 pid=17508 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=ldconfig exe=/usr/sbin/ldconfig subj=system_u:system_r:ldconfig_t:s0 key=(null)

Hash: ldconfig,ldconfig_t,initrc_tmp_t,lnk_file,read

audit2allow

#============= ldconfig_t ==============
allow ldconfig_t initrc_tmp_t:lnk_file read;

audit2allow -R
require {
	type initrc_tmp_t;
	type ldconfig_t;
	class lnk_file read;
}

#============= ldconfig_t ==============
allow ldconfig_t initrc_tmp_t:lnk_file read;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-200.fc18.x86_64
type:           libreport

Potential duplicate: bug 799359
Comment 1 Miroslav Grepl 2013-07-03 07:38:13 EDT

*** This bug has been marked as a duplicate of bug 799359 ***

Note You need to log in before you can comment on or make changes to this bug.