Bug 980795 - enhance password tool with some usability fixes
enhance password tool with some usability fixes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: FutureFeature
Depends On: 977479
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 05:08 EDT by haiyang,dong
Modified: 2014-01-21 14:43 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Enhancement
Doc Text:
This feature enhances the password tool usability. Previously the usability of the new password tool was suboptimal so some changes were made. It provides a command list in the initial text and also tells the user the current state of SSH passwd auth Possible commands: admin Set the password of the user 'admin' help Show this help. [`help --all` to show all available functions] q Quit this tool quit Quit this tool root Set the password of the user 'root' ssh Enable or disable the SSH password authentication [INFO] SSH password authentication is currently enabled It also provides overrides for some commands: admin to set admin password root for set root password ssh for set ssh password authentication q for quit
Story Points: ---
Clone Of: 977479
Environment:
Last Closed: 2014-01-21 14:43:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-07-03 05:08:02 EDT
+++ This bug was initially created as a clone of Bug #977479 +++

Description of problem:
Primarily Usability related.

1.  Provide command list in initial text

Currently:

 Password Configuration

 Enter ? for help.

>

We could list the set_admin_password, etc there so users have some idea what to do without running help.

2.  tell the user the current state of SSH passwd auth

Old tool said "Current Status is Enabled/Disabled".  This should do something similar

3.  possibly provide overrides for some commands 
     ( admin to set admin password, root for root password, ssh for ssh, q for quit)

Optional, but might be nicer to have some quick commands that simply wrap the top level commands like:

admin --> set_admin_password
root --> set_root_password
ssh --> set_ssh_password_authentication
q --> quit
Comment 1 haiyang,dong 2013-07-03 05:08:33 EDT
Also missed enhanced function that this RFE bug talked about in rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso,
so need clone it from upstream bug Component to downstream Component in order to also track it in rhev-h
Comment 7 haiyang,dong 2013-10-27 05:08:29 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

1.  It provide command list in initial text and also tell the user the current state of SSH passwd auth

[root@dhcp-9-27 admin]# /usr/libexec/ovirt-config-password 


 Password Configuration


Possible commands:
admin  Set the password of the user 'admin'
help   Show this help. [`help --all` to show all available functions]
help   Show this help. [`help --all` to show all available functions]
q      Quit this tool
quit   Quit this tool
root   Set the password of the user 'root'
ssh    Enable or disable the SSH password authentication

[INFO] SSH password authentication is currently enabled

> 

2. It provided overrides for some commands 
     ( admin to set admin password, root for set root password, ssh for set ssh password authentication, q for quit)

so this bug has been fixed, change it into "VERIFIED".

About met duplicated line "help   Show this help. [`help --all` to show all available functions]" help info in console issue, has report Bug 1023700 to track it.
Comment 10 Cheryn Tan 2013-11-07 19:35:12 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 errata-xmlrpc 2014-01-21 14:43:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.