This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 980826 - Do not have such command 'haproxy_watcher' in rhcsh which is listed in help content
Do not have such command 'haproxy_watcher' in rhcsh which is listed in help c...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 1006146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 06:06 EDT by Jianwei Hou
Modified: 2015-05-14 19:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2013-07-03 06:06:11 EDT
Description of problem:
Run 'haproxy_ctld --help' in rhcsh, a 'haproxy_watcher' command is printed out, however, there is no such command available

Version-Release number of selected component (if applicable):
On devenv_3441

How reproducible:
Always

Steps to Reproduce:
1. Create a scalable application 
rhc app create php1s php-5.3 -s
2. SSH into this application, run command 'haproxy_ctld --help'
3. Run command 'haproxy_watcher'

Actual results:
After step 2:
[php1s-jhou.dev.rhcloud.com 595732676428353530494976]\> haproxy_ctld --help

Usage: /var/lib/openshift/595732676428353530494976/haproxy/usr/bin/haproxy_ctld.rb
Control scaling features for this application.  Has two operating modes, auto
and manual.  Manual scaling options will run requested action and exit, auto
scaling options will stay running in the foreground.

  -h|--help         Display this help menu

Manual scaling options:
  -u|--up           Trigger a gear_up event and add an additional gear
  -d|--down         Trigger a gear_remove event and remove a gear
  --debug           Puts logger into debug mode

Auto scaling options:
  -a|--auto         Enable auto-scale
  --debug           Puts logger into debug mode

Notes:
1. To start/stop auto scaling in daemon mode run:
    haproxy_watcher (start|stop|restart|run|)

After step 3:
[php1s-jhou.dev.rhcloud.com 595732676428353530494976]\> haproxy_watcher
bash: haproxy_watcher: command not found

Expected results:
Should not print 'haproxy_watcher' related content if we don't have such command

Additional info:
Comment 1 Dan McPherson 2013-09-19 17:31:39 EDT
Fixed along with:

https://github.com/openshift/origin-server/pull/3667
Comment 3 Jianwei Hou 2013-09-21 22:23:24 EDT
Verified on devenv_3810, the message is updated

[php1s-jhou.dev.rhcloud.com 523e53a6cdcfb1d6dc000001]\> haproxy_ctld -h

Usage: /var/lib/openshift/523e53a6cdcfb1d6dc000001/haproxy/usr/bin/haproxy_ctld.rb
Control scaling features for this application.  Has two operating modes, auto
and manual.  Manual scaling options will run requested action and exit, auto
scaling options will stay running in the foreground.

  -h|--help         Display this help menu

Manual scaling options:
  -u|--up           Trigger a gear_up event and add an additional gear
  -d|--down         Trigger a gear_remove event and remove a gear
  --debug           Puts logger into debug mode

Auto scaling options:
  -a|--auto         Enable auto-scale
  --debug           Puts logger into debug mode

Notes:
1. To start/stop auto scaling in daemon mode run:
    haproxy_ctld_daemon (start|stop|restart|run|)
Comment 4 Ben Parees 2014-01-21 16:45:05 EST
*** Bug 1006146 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.