Bug 980836 - WebServiceWorkItemHandler fails to find service among multiple imports.
WebServiceWorkItemHandler fails to find service among multiple imports.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER3
: 6.0.0
Assigned To: Maciej Swiderski
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 06:25 EDT by Marek Baluch
Modified: 2014-08-06 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
process definition (7.71 KB, application/xml)
2013-07-03 06:25 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-07-03 06:25:50 EDT
Created attachment 768191 [details]
process definition

When a service is looked up in WebServiceWorkItemHandler using import elements then the error bellow will be throw.

03/07 12:21:33,386[main] ERROR workitem.webservice.WebServiceWorkItemHandler.executeWorkItem  - Error when executing work item
org.apache.cxf.service.factory.ServiceConstructionException: Could not find definition for service {http://www.webservicex.net}SimpleService.

The root cause is that the first imported WSDL does not contain the service. The second does but will not be checked anymore.

See attached process definition.
Comment 1 Maciej Swiderski 2013-08-27 13:16:02 EDT
ensure that all imports will be processed when creating WS client. Pushed to master and 6.0.x

https://github.com/droolsjbpm/jbpm/commit/e88d1a2db9554fe8ca205544fa54a06958e8f59f
Comment 2 Marek Baluch 2013-09-18 08:50:51 EDT
Verified on ER3.

Note You need to log in before you can comment on or make changes to this bug.