Bug 980847 - Dist-geo-rep: In case of unknown host, geo rep session create commands gives error ' Unable to get statefile's name' instead of telling unknown host or host not reachable
Dist-geo-rep: In case of unknown host, geo rep session create commands gives...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 06:52 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-03 06:52:08 EDT
Description of problem:
Dist-geo-rep:  In case of unknown host, geo rep session create commands gives error ' Unable to get statefile's name' instead of telling unknown host or host not reachable

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta1-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.while creating geo rep session give hostname which is not reachable or wrong

[root@hulk ~]# ping -c 2 baratheon.blr.redhat.com
ping: unknown host baratheon.blr.redhat.com


[root@hulk ~]# gluster volume geo master1 baratheon.blr.redhat.com::slave1 create
Unable to get statefile's name
geo-replication command failed


Actual results:
n case of unknown host, geo rep session create commands gives error ' Unable to get statefile's name'

Expected results:
Should give proper error message that unknown host or not reachable

Additional info:
Comment 1 Rachana Patel 2013-07-03 06:56:06 EDT
If IP is wrong/not reachable it gives error 'Unable to fetch slave volume details.'

e.g.
[root@hulk ~]# gluster volume geo master1 10.70.4.147::slave1 create
Unable to fetch slave volume details.
geo-replication command failed



[root@hulk ~]# ping -c 2 10.70.4.147
PING 10.70.4.147 (10.70.4.147) 56(84) bytes of data.

--- 10.70.4.147 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 11000ms



Expected results:
Should give proper error message that node is not reachable.
Comment 4 Avra Sengupta 2013-07-03 09:28:06 EDT
Fix in https://code.engineering.redhat.com/gerrit/#/c/9671/
Comment 5 Rachana Patel 2013-08-08 06:29:36 EDT
verified with -3.4.0.18rhs-1.el6rhs.x86_64
working as per expected result , hence moving to verified
Comment 6 Scott Haines 2013-09-23 18:38:43 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 7 Scott Haines 2013-09-23 18:41:28 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.