Bug 980865 - asus_nb_wmi isn't loaded during boot (was: Fn keys aren't recognized correctly (ASUS UX21E))
asus_nb_wmi isn't loaded during boot (was: Fn keys aren't recognized correctl...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 07:40 EDT by Artur Szymczak
Modified: 2013-09-18 16:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 16:57:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Szymczak 2013-07-03 07:40:28 EDT
Description of problem:
HotKeys (Fn+Fx) aren't recognized correctly in xev.
KEY - status
SLEEP - OK
WIFI - OK
BRIGHTNESS_DOWN - no output in xev (but works fine)
BRIGHTNESS_UP - no output in xev (but works fine)
BACKLIGHT (on/off) - no
MappingNotify event, serial 62, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

KeyPress event, serial 62, synthetic NO, window 0x2200001,
    root 0x91, subw 0x0, time 554294, (313,107), root:(314,150),
    state 0x0, keycode 253 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 62, synthetic NO, window 0x2200001,
    root 0x91, subw 0x0, time 554294, (313,107), root:(314,150),
    state 0x0, keycode 253 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

DISPLAY - OK
TOUCHPAD - OK
MUTE - no
MappingNotify event, serial 72, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

FocusOut event, serial 72, synthetic NO, window 0x2200001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 72, synthetic NO, window 0x2200001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 72, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 

VOLUME_DOWN - OK
VOLUME_UP - no
FocusOut event, serial 77, synthetic NO, window 0x2200001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 77, synthetic NO, window 0x2200001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 77, synthetic NO, window 0x0,
    keys:  1   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Version-Release number of selected component (if applicable):
Fedora 19 (LXDE Spin) fully updated

How reproducible:


Steps to Reproduce:
1. Install + update (including testing) F19 (LXDE Spin) 
2. Test Fn keys.
3.

Actual results:
As above

Expected results:
All Fn keys should have proper description/function, that will allow map them to proper program/function in system.

Additional info:
Comment 1 Artur Szymczak 2013-07-03 07:41:50 EDT
On Fedora 18 (Live CD LXDE) only Brightness_{UP,DOWN} and BACKLIGHT wasn't working. So I think it is regression.
Comment 2 Artur Szymczak 2013-07-12 06:08:02 EDT
Ok,

the problem is related to this module: "asus_nb_wmi" it isn't automatically loaded by system. If you load it all Fn keys work like a charm. (Fn + {F1, F2, F5, F6, F7, F8, F9, F10, F11, F12, T, C, V})

So, currently the bug is that asus_nb_wmi isn't loaded by default.
Comment 3 Josh Boyer 2013-09-18 16:41:35 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Artur Szymczak 2013-09-18 16:56:25 EDT
Fixed.
Comment 5 Josh Boyer 2013-09-18 16:57:25 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.