Bug 980874 - SELinux is preventing /usr/bin/qemu-system-x86_64 from 'open' accesses on the file /mnt/globalsync/fedora/fedora-alt/stage/19-RC3/Fedora/x86_64/iso/Fedora-19-x86_64-netinst.iso.
SELinux is preventing /usr/bin/qemu-system-x86_64 from 'open' accesses on the...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:97bb3887750dc6abee74bb8278b...
:
: 980875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 08:09 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 08:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2013-07-03 08:09:23 EDT
Description of problem:
Gnome Boxes installation from image on read-only NFS storage.
SELinux is preventing /usr/bin/qemu-system-x86_64 from 'open' accesses on the file /mnt/globalsync/fedora/fedora-alt/stage/19-RC3/Fedora/x86_64/iso/Fedora-19-x86_64-netinst.iso.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow confined virtual guests to manage nfs files
Then you must tell SELinux about this by enabling the 'virt_use_nfs' boolean.
You can read 'virt_selinux' man page for more details.
Do
setsebool -P virt_use_nfs 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If you believe that qemu-system-x86_64 should be allowed open access on the Fedora-19-x86_64-netinst.iso file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep qemu-system-x86 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:system_r:svirt_t:s0:c18,c653
Target Context                system_u:object_r:nfs_t:s0
Target Objects                /mnt/globalsync/fedora/fedora-alt/stage/19-RC3/Fed
                              ora/x86_64/iso/Fedora-19-x86_64-netinst.iso [ file
                              ]
Source                        qemu-system-x86
Source Path                   /usr/bin/qemu-system-x86_64
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-1.4.2-4.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-03 14:03:13 CEST
Last Seen                     2013-07-03 14:03:13 CEST
Local ID                      f4d5e11b-a964-466d-9958-e13754c60801

Raw Audit Messages
type=AVC msg=audit(1372852993.283:478): avc:  denied  { open } for  pid=4215 comm="qemu-system-x86" path="/mnt/globalsync/fedora/fedora-alt/stage/19-RC3/Fedora/x86_64/iso/Fedora-19-x86_64-netinst.iso" dev="0:40" ino=70444182 scontext=unconfined_u:system_r:svirt_t:s0:c18,c653 tcontext=system_u:object_r:nfs_t:s0 tclass=file


type=SYSCALL msg=audit(1372852993.283:478): arch=x86_64 syscall=open success=yes exit=EBUSY a0=7f9e82072040 a1=80800 a2=0 a3=1 items=0 ppid=1 pid=4215 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=qemu-system-x86 exe=/usr/bin/qemu-system-x86_64 subj=unconfined_u:system_r:svirt_t:s0:c18,c653 key=(null)

Hash: qemu-system-x86,svirt_t,nfs_t,file,open

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-07-03 08:45:20 EDT
Alert above tells you what to do.


*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow confined virtual guests to manage nfs files
Then you must tell SELinux about this by enabling the 'virt_use_nfs' boolean.
You can read 'virt_selinux' man page for more details.
Do
setsebool -P virt_use_nfs 1
Comment 2 Daniel Walsh 2013-07-03 08:45:42 EDT
*** Bug 980875 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.