Bug 980913 - openshift-enterprise-release does not correctly require ruby and rubygems
openshift-enterprise-release does not correctly require ruby and rubygems
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
1.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 09:45 EDT by Jason DeTiberus
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-enterprise-upgrade-1.2.1-1.el6op
Doc Type: Bug Fix
Doc Text:
Due to missing requirements in the RPM spec file for the openshift-enterprise-release package, the rubygems and ruby packages would not be installed in some cases. This was most common on OpenShift Enterprise infrastructures that were only hosting ActiveMQ. With this fix, the RPM spec file has been updated, and the rubygems and ruby packages are installed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:18:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-07-03 09:45:12 EDT
Description of problem:
Install from a bare system (as the TPS tests do) causes an error in %post during install due to missing ruby dependency

Version-Release number of selected component (if applicable):
openshift-enterprise-release-1.1-1.el6op

How reproducible:
Always

Steps to Reproduce:
1. Install openshift-origin-release on a system without ruby

Actual results:
Install completes with a failure in %post

Expected results:
No failures during install

Additional info:
This generally should not be an issue, since anyone installing openshift-enterprise-release would have ruby installed as a prerequisite for running openshift, however this affects TPS tests where the rpms are installed on a bare system.
Comment 2 Johnny Liu 2013-07-03 22:48:48 EDT
Not only ruby is required but also rubygems is required by openshift-origin-release.
Comment 3 John W. Lamb 2013-07-09 15:35:07 EDT
System ruby and rubygems packages need to be added to specfile for this package
Comment 4 Brenton Leanhardt 2013-07-10 13:44:30 EDT
commit 7206fdebf7c4da97e2ca22ce8335444d8e97e277
Author: Brenton Leanhardt <bleanhar@redhat.com>
Date:   Wed Jul 10 13:43:11 2013 -0400

    Bug 980913 - openshift-enterprise-release does not correctly require ruby and rubygems
Comment 6 Johnny Liu 2013-07-17 23:20:31 EDT
Verified this bug with 1.2/2013-07-17.1 puddle, and pass.

When installing openshift-enterprise-release, ruby and rubygems will be pulled in as dependency. And no any error is seen in %post during installation.
Comment 9 errata-xmlrpc 2013-08-05 13:18:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.