Bug 980984 - app icon not visible in the right panel where virtual workspaces are shown.
app icon not visible in the right panel where virtual workspaces are shown.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-desktop (Show other bugs)
19
athlon Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 14:15 EDT by jd1008
Modified: 2013-07-26 11:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 06:23:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jd1008 2013-07-03 14:15:25 EDT
Description of problem:

I still do not see the large icon on the right panel for currently running apps in a workspace that is in focus and active.
Thus I still am unable to un-iconify an iconified app.

Version-Release number of selected component (if applicable):
mate-desktop-1.6.1-8.fc19.x86_64

How reproducible:
Right click on the workspace display panel, and select properties and from properties select Right, and set it's width to at least 43 pixels
because otherwise you will not see the super tiny icon of the running
app in the tiny virtual desktop within the Panel.

Then open any app.

You will not see the app's large icon whcih when you click, it iconifies the app, and click it again to un-iconify the app.

Thus, if you use the app's window to iconify the app, you will  have no
means to un-iconify it.



Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Wolfgang Ulbrich 2013-07-03 15:10:33 EDT
I don't understand what is really missing?
https://dl.dropboxusercontent.com/u/49862637/Mate-desktop/Bugs/right_panel.png
Here with TraditionalOK theme i see in the right panel:
- the show desktop applet
- the windows-list applet
- the workspace-switcher applet
In the workspace-switcher i see all icons from open apps.
That's the normal gnome-2 / MATE behaviour.

(In reply to jd1008 from comment #0)
> How reproducible:
> Right click on the workspace display panel, and select properties and from
> properties select Right, and set it's width to at least 43 pixels
> because otherwise you will not see the super tiny icon of the running
> app in the tiny virtual desktop within the Panel.
> 
> Then open any app.
> 
> You will not see the app's large icon whcih when you click, it iconifies the
> app, and click it again to un-iconify the app.
That sounds for me like gnome-shell handles a application in the panel.

Do you have a picture from what you expected?
Comment 2 jd1008 2013-07-03 17:24:58 EDT
(In reply to Wolfgang Ulbrich from comment #1)
> I don't understand what is really missing?

I don't either. But I can reproduce the problem at will.
This is a fresh installation (Last night) of FC19
with Mate desktop, as I do not like Gnome 3.

> https://dl.dropboxusercontent.com/u/49862637/Mate-desktop/Bugs/right_panel.
> png
> Here with TraditionalOK theme i see in the right panel:
> - the show desktop applet
> - the windows-list applet
> - the workspace-switcher applet
> In the workspace-switcher i see all icons from open apps.
> That's the normal gnome-2 / MATE behaviour.
> 
> (In reply to jd1008 from comment #0)

> 
> Do you have a picture from what you expected?

How can I? I do not have 2 computers or 2 different 
linux installations with Mate on both.
Comment 3 jd1008 2013-07-26 10:42:44 EDT
I PROTEST AS LOUDLY AS I CAN!!
YOU CANNOT CLOSE THIS BUG BECAUSE IT IS STILL PRESENT.
IT IS STILL A PROBLEM HERE!!!
I DO NOT SEE THE APPLICATION'S ICON IN THE PANEL FOR ANY GIVEN WORKSPACE.
I CAN ONLY SEE THE ICONS IN THE WS SWITCHER BOXES. I HAVE 14 WS switcher boxes.
IF I MINIMIZE AN APP, IT IS GONE !!! I CANNOT BRING IT BACK!!!

HOW CAN YOU DECLARE IT CLOSED??
I HAVE NO IDEA HOW TO DESCRIBE IT TO YOU ANY CLEARER THAN THIS!!!
Comment 4 Wolfgang Ulbrich 2013-07-26 10:57:21 EDT
1. Seeing only a icon in workspace-switcher box is a normal behavior !
2. Not all applications shown an icon at this place, that's also a normal behavior, file out bugs against this applications!
3. if i minimize/restore ie. firefox i see the icon again!
Comment 5 Wolfgang Ulbrich 2013-07-26 11:05:26 EDT
PS: you can re-open the report for yourself, but don't expect that someone fix a non bug.
Comment 6 leigh scott 2013-07-26 11:08:06 EDT
(In reply to jd1008 from comment #3)
> I PROTEST AS LOUDLY AS I CAN!!
> YOU CANNOT CLOSE THIS BUG BECAUSE IT IS STILL PRESENT.
> IT IS STILL A PROBLEM HERE!!!

So if it's a priority for you report it upstream.

https://github.com/mate-desktop/mate-desktop/issues

> HOW CAN YOU DECLARE IT CLOSED??

It's not a packaging issue so it isn't our job to fix.

> I HAVE NO IDEA HOW TO DESCRIBE IT TO YOU ANY CLEARER THAN THIS!!!

Does this make is clear to you?
Comment 7 jd1008 2013-07-26 11:17:00 EDT

(In reply to leigh scott from comment #6)

> So if it's a priority for you report it upstream.
> 
> https://github.com/mate-desktop/mate-desktop/issues

So, why do you not push it upstream, since it is a Fedora package
installed from fedora's own repo's??

Note You need to log in before you can comment on or make changes to this bug.